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Introduction 

OpenOffice is an open source Office Suite package originally designed by Sun 
Microsystems.  OpenOffice is much like Microsoft Office but free to use.  The 
software can be freely downloaded and used. 
 
OpenOffice Calc is much like using Microsoft Excel. 
 

What is a Spreadsheet? 

A spreadsheet is the computer equivalent of a paper ledger sheet. It consists of a 
grid made from columns and rows. It is an environment that can make number 
manipulation easy and somewhat painless.  

The math that goes on behind the scenes on the paper ledger can be 
overwhelming. If you change the loan amount, you will have to start the math all 
over again (from scratch). The nice thing about using a computer and spreadsheet 
is that you can experiment with numbers without having to redo all the 
calculations. Let the COMPUTER do the calculations for you! Once you have 
the formulas set up, you can change the variables that are called from the formula 
and watch the answers change. Spreadsheets are instantly updated if one of the 
entries is changed. NO erasers! NO new formulas! NO calculators!  

Spreadsheets are made up of columns, rows, and cells (intersection of a column 
and row.  A cell can contain data including text (strings or labels), numeric data, 
and formulas (mathematical equations). 
 

Starting OpenOffice Calc 

Procedure 
 

1. Click Start, Programs, OpenOffice.org 1.0.3, OpenOffice Calc.  
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OpenOffice Calc (Spreadsheet) Basics 

The picture below shows the Calc screen.  
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The Menu toolbar contains the main menus of the Calc module. The Function 
toolbar provides user access to function icons such as Open, Save, Copy, Cut, 
Paste and other common tasks in Open Office. The Object toolbar consists of a 
set of tools that are specific to calculation and cell formatting (number format, text 
alignment, borders). Finally, the Calculation toolbar is intended for the entry of 
formulae necessary for your calculations, and also shows you the position of the 
cursor within the spreadsheet. 

On the left of the screen, you will notice the Instrument toolbar (shown here 
on the right). This toolbar provides the tools that you will need to work with 
your spreadsheet. The basic functions of the toolbar are explained in this 
`How-to'. At the bottom of the screen, you will notice the Status Bar. This 
bar provides essential information such as the sheet that you're currently 
working on, the page style, and in normal mode, the sum of the cell in which 
the cursor is situated. 

You will also notice that the folder you have just opened contains three 
worksheets by default, indicated by the presence of three small tabs above 
the Status Bar and bearing the names: Sheet1, Sheet2, Sheet3. 

The spreadsheet is represented as a grid comprising cells, with each cell 
bearing a unique reference. A cell is referenced by its column (vertical 
reference), given here as a letter (e.g. A...Z etc.), and its line (horizontal 
reference), given here as a number (e.g. 1...65000 etc.). These references 
appear as grey column and line headers on the spreadsheet. Thus, the first 
cell in the first line (the one at the uppermost left hand corner) bears the 
reference A1. 

Creating a New Document 

Procedures 
 

1. Type CTRL+N on your keyboard (hold down the CTRL key and type N). 
2. Select File, New, Spreadsheet from the Menu Bar   OR 

3. Click on the New Document Icon  on the Function Bar and select 
Spreadsheet. 

 

Entering Data 

Procedures 
 
To enter text, values or a formula: 

1. Click on the cell you wish to enter information. 
2. Type the information. 
3. Press the ENTER key on the keyboard or press one of the arrow keys. 
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Selecting (Highlighting) Cell(s) 

To Select One Cell 

Procedure 
 

1. Click in the cell. (The active cell is already selected.) 
 

To Select a Range of Cells (e.g. A1:G5) 

Procedures 
 

1. On the first cell of the range (e.g. A1), click and hold the left mouse button 
while dragging the mouse to the last cell of the range (e/g. G5).   

2. All cells will turn black except the first cell will remain white. 
 

To Select a Column or Row 

Procedure 
 

1. Click on the column or row heading in gray. 

Deleting Cell(s) 

Procedures 
 

1. Select the cell(s) you wish to delete. 
2. Press the DELETE key on the keyboard.  The following window will 

appear. 

 
3. Check the boxes of what you wish to delete (e.g. checking Formats will 

delete things like bold, italics, font color, borders). 
4. Click the OK button. 

Opening and Saving a File 

The opening, saving, and printing of files are the most common actions in a word 
processor, and therefore, they have to be very easy and accessible. 
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Opening a File 

Procedures 
 

1. Select the File menu, Open from the Menu Bar,  OR  

2. Click the Open File icon  on the toolbar. 
3. An Open File Dialog box will appear as shown below. From the drop 

down list (shown by the arrow) indicated below, choose the directory that 
contains the file you wish to open. 

 

4. When a list of files appears, double click on the filename to open the file. 

Saving a File 

Procedures 
 

1. Choose File, Save from the Menu Bar, OR  

2. Click the Save icon  on the Function Bar.  

3. If you are saving for the first time, a Save File Dialog Window will be 
displayed. 

4. Type a filename and choose a location to save the file. 

5. If you wish to save your file as a Microsoft Excel file format, change the 
Save as type to Microsoft Excel 97/2000/XP. 
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6. Click the Save button. 

Cut, Copy, Paste 

You can perform four main actions on a selected text: copying, cutting, deleting, 
and formatting.  

Cut and Paste 

This allows the user to move selected text so that it can be placed somewhere 
else in the document or in another document. 
 
Procedures 
 

1. Select cell(s) that contain the information you wish to cut (move). 

2. Click the Cut  button on the toolbar or CTRL + X on the keyboard. 

3. Click in the cell where you want to paste the information. 

4. Click the Paste  button on the toolbar or CTRL+ V on the keyboard. 

Copy and Paste 

This allows the user to create a duplicate (copy) of the selected text to be placed 
somewhere else in the document or in another document. 
 
Procedures 
 

1. Select cell(s) you wish to cut (move). 

2. Click the Copy  button on the toolbar or CTRL + C on the keyboard. 
3. Place the cursor where to place the cut cell(s). 
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4. Click the Paste  button on the toolbar or CTRL+ V on the keyboard. 

Formatting Text 

The formatting action in Open Office is slightly different from other Office 
applications such as Microsoft Office.  There are two ways to format text in Open 
Office Writer. 
 
Procedure 
 

1. Use the buttons provided from the Toolbar or Format Menu. 

Changing the Font/Font Size 

Font is the style of writing and font size is the size of the text with a 12-point size 
being 1/6 of an inch. 

 
Procedures 
 

1. Select the cell(s) you wish to change. 

2. On the toolbar, click the  first drop-down arrow to 
change the font and the second drop down arrow to change the font size. 

Bold, Italics, Underline 

Procedures 
 

1. Select the cell(s) you wish to format. 

2. Click on the attribute icon you wish to apply such as on the 

Toolbar. These buttons transform the selected text (in sequence from left 
to right) into Bold, Italics, and Underlined.  

3. With the cell(s) still selected, click the button again to turn the feature off. 

Note: More formatting options can be accessed by selecting Format menu, 
Cells.  
 

Cell Alignment 

Procedures 
 

1. Select the cell you wish to change. 

2. Click on one of the alignment icons  on the function toolbar 

to modify the text alignment (left, center, right, or justified).  
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Font Color 

Procedures 
 

1. Select the cell (s) you wish to change. 

2. Click the font color button  on the toolbar and pick the color of your 
choice. 

Background (highlighting) Color 

Procedures 
 

1. Select the cell (s) you wish to change. 

2. Click the background color button  on the toolbar and pick the color of 
your choice.  

Undo/Redo Buttons 

If you perform an action that does not give you the desired result, you can use 

the Undo button to reverse the last action.  Likewise, the Redo button can 
be used to Redo an action that has been undone. 

Spelling/Grammar Check 

There is only a spell check available in Open Office.  Words spelled incorrectly 
will be underlined in red if the spell check toggle button is turned on. 
 
Procedures 

1. To turn the spell check on/off as you are typing, click the  button on the 
toolbar. 

2. If you wish to spell check the entire document in order to make 

corrections, click the  button on the toolbar. 

Headers/Footers 

A header/footer is a piece of information you would like to have appear at the top 
(header) or bottom (footer) of every page such as page numbers. 

Adding Headers/Footers 

A header is space at the top of the page reserved for such things as page 
numbers.  A footer is space reserved at the bottom of the page. 
 
Procedures 
 

1. From the menu toolbar, choose Format, Page. 
2. Click on the tab Footer. 
3. In the window that appears, click on the checkbox that says Footer on. 
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4. The button More allows you to add a border or background to the footer. 
5. Click the Edit button. 
 

The following window will appear.  

 

6. Click in the area you want to place information (each area corresponds to 
the area of your page). 

7. Use the buttons to add information (e.g. page numbers). For example, 

click on the icon Page , you will see the page number written into the 
selected window or type your own information. 

8. Click OK to return to the Page Style window.  
9. Click OK to close this window.  

 

Deleting a header/footer 

Procedures 
 

1. Click Format menu, Click Page… 

2. Click Header or Footer tab. 

3. Deselect Header or Footer checkbox. 

4. Click Yes to delete the text in the header or footer. 

Adding Pictures 

Follow these steps if you wish to add pictures that are saved in a file. 
 
Procedures 
 

1. Place your cursor where you want to place a picture. 
2. Click Insert menu, Click Graphics, Click From File (as shown below) 



 12

 
3. Pick the location where the file has been saved. 
4. Double click filename to insert into document. 

 
Note: Use the following toolbar to modify picture attributes. 
 

 

 

Creating Formulas/Calculations 

As mentioned above, the boxes that you see formed by the grid are called cells. 
You can enter text, numbers or formulae in these cells. Of course, the whole 
purpose of a spreadsheet application is to be able to carry out calculations within 
these cells. A calculation can be simply adding two numbers or taking the 
average of ten numbers. 

Note: A right mouse button click in the box where Sum is written will give you 
access to a context-sensitive menu that proposes other choices, such as mean, 
maximum, minimum... 

Formula Basics 

• Just like in Microsoft Excel, formulas are started with an EQUAL (=) sign. 
(e.g. =b3+b4) 

• Use cell references (e.g. b3) instead of actual values (e.g. 56) wherever 
possible. 

• Use FUNCTIONS (e.g. SUM, AVERAGE) to save time when creating 
formulas.  

 
e.g.    =SUM(A1:A9) 

Instead of =A1+A2+A3+A4+A5+A6+A7+A8+A9 
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By typing the colon [ : ] between the cell references, you have told the 
software that you want to add up the values in the range of cells from A1 
to A9. The range is indicated on the screen by a red border.  By typing 
“=sum()”, you are telling the software the type of mathematical operation 
that you want to carry out on the referenced cells that are between 
parentheses. 

You can also select the ranges to be added together using the mouse. After 
having typed "= sum()" into the target cell, click on the first cell and whilst holding 
the mouse button down, drag the mouse to the last cell of the range, and then let 
go of the mouse button, and you will see the end of the formula inserted in 
automatically into the Formula bar. 

Note : If the number that is displayed is too big to be displayed completely in the 
cell, it will be replaced by a series of musical flat symbols (###). In order to adjust 
the size of the cell, all you have to do is click on the right-hand column separator  

 

of any given column and drag the separator rightwards (to broaden) or leftwards 
(to narrow). The same function can be reached through the command Format - 
Column - Optimal width. 

Cell References 

It is important to grasp the basics of references when you want to carry out 
calculations on cells containing formulae. 

A relative reference is a range whose references are adjusted when the formula 
is moved:  
e.g. If you copy the formula "=sum(A1:A9)" to column B, it will become 
"=sum(B1:B9)"  

An absolute reference is used when a calculation has to refer to a precise or 
absolute cell of the spreadsheet. This is written using dollar signs ($) around the 
cell reference. For example, typing $A$1 will make column A and row 1 absolute 
or fixed. 
 
e.g. If you copy the formula “=$B$3 * B8” from cell C8 to cell C9, the formula 
would read “=$B$3 * B9. Notice the first part of the formula (=$B$3) did not 
changed when copied.  A good example of when you might use an absolute cell 
reference is when you are calculating the tax on an item.  The tax (7%) will not 
change.  Each item will be multiplied by the same tax amount. 
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Formatting Cell(s) 

Text Alignment 

Use these buttons  found on the toolbar to change the alignment of cell 
contents.  
 

Merging Cells 

Sometimes you might want to center a title between many columns.  

Procedures 
 

1. Select all the cells in which the title is to be centered between. 
2. In the menu toolbar, select Format, Merge Cells, Define.  
3. The cells are now merged into one large cell.  Click the Center button 

 on the toolbar to center text within this cell. 
4. Click the OK button.  

 

Other Formatting Hints 

The ‘Cell Attributes’ window (click Format, Cells) below includes other tabs for 
cell formatting (e.g. Fonts, Font Effects, Alignment, etc). The function toolbar 
also contains some of these formatting functions. 
 

 

Example: Adding Borders 

A border such as a thick dark border can be added to emphasize a range of 
cells.   
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Procedures 
 

1. Select the cells for which you want to add a border. 
2. Choose the Format menu, Cells and click on the tab called `Borders'. 

3. Choose the style and thickness of the border  you wish to use. 
 

Renaming Sheets 

Your spreadsheet contains three sheets, Sheet 1, 2, 3. Each sheet can be 
renamed. 
 
Procedures 
 

1. Right-click on the Sheet name (e.g. Sheet 1). 
2. Click Rename. 
3. Enter a name for your sheet and click the OK button; the sheet will then 

display the new name in the tab.  

Page Settings 

Page settings allows you to change settings related to a page as a whole such as 
changing the page orientation (e.g. portrait  - 8.5” x 11” or landscape- 11” x 8.5”), 
adding headers/footers, and margins. 
 

Changing Page Orientation 

Procedures 
 

1. From the menu toolbar, choose Format, Page. 
2. Click on the tab Page. 
3. At the section Orientation, click on the radio button Landscape. 
4. Confirm with OK. 
 

To verify the change in page orientation, click the File menu, Preview. 

Other Page Setting Options 

• In the Margins section of the Page tab, you set the margin sizes. If you 
set them beyond the printing area, a message will warn you.  

• In the Layout settings section of the Page tab, Page Layout lets you 
select how to align the content of the cells inside the sheet. 

• In the Sheet Tab under Scale, the Reduce/enlarge printout option 
allows you to decrease or increase the size of the printed page. 
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• In the Sheet Tab under Scale, the Fit printout on number of pages 
option allows you to determine the exact number of pages on which the 
spreadsheet will be printed. The size of the sheets will be adjusted to fit 
that number of pages. 

 

Using the AutoFormat feature  

This feature formats a range of cells with color, borders, font, font size, etc. 
automatically rather than you having to do it one step at a time. 
 
Procedures 
 

1. Select the range of cells you wish to format. 

2. Select the Format menu, AutoFormat, or click the AutoFormat button  
on the toolbar to the left of your screen.   

3. The following window will appear.  
 

 
 

4. Click the format you want from the left side. You can create your own 
format (see the Add.... button to the right) and delete it when you do not 
want it anymore. By clicking on the More button, some additional 
formatting options appear. If you modify them, the result will be presented 
in the preview image displayed in the AutoFormat window. 
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5. Click OK. 

Creating Charts 

A chart (e.g. bar chart, pie chart) is a visual representation of data contained in a 
spreadsheet.   
 
Procedures 
 

1. Select the cells you wish to include in the chart. 
2. Click the Insert menu, Chart… 
3. Step 1: Choose whether you want your chart in the same sheet as your 

data or a new sheet. 
4. Click Next. 
5. Step 2: Choose a chart type from the list. 
6. Click Next. 
7. Step 3: Choose a chart sub-type (variant) from the list. 

Choose data series in rows or columns. 
8. Click Next. 
9. Step 4: Add a title to your chart. 
10. Click the Create button. 

 

Printing a File 

It is a good habit to check how the document will look when printed, before 
printing. It can be done by using the Page Preview feature.  
 
Procedures 
 

1. Select File, Page Preview from the menu bar to switch to the Page 
Preview Mode.  

2. Click Page Preview  button in Page Preview to close Page Preview 

and return to the main document. 
 
You may want to print part of your spreadsheet, the entire workbook (all 
worksheets) or even only one sheet. 
 

Printing a Selected Area of your Worksheet 

Procedures 
 

1. Select the cell(s) you wish to print. 
2. Select the File menu, Print.  
3. In the dialog box that appears, click on the box Selection in `Print range'.  
4. Click OK. 
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Printing a Single Worksheet 

Procedures 
 

1. Click the File menu, Print.  
2. In the dialog box that appears, under Print Range click on the radio 

button Pages and enter the page number that you wish to print. If you wish 
to print more than one page at a time such page 2 and 3, you would enter 
2,3. 

3. Click OK. 
 

Printing Multiple Worksheets 

Procedures 
 

1. Select the worksheets you wish to print by clicking the first sheet tab at the 
bottom of the page, press and hold the CTRL key on the keyboard and 
select the remaining sheets you wish to print. 

2. Click on the icon Quick printing in the function toolbar. 
3. To undo selected sheets, press and hold the CTRL key and click once 

more on the sheet tab. 
 
 
 
Source: Gautier, Sophie (January 16, 2002). OpenOffice.org Documentation 
Project.  Available at http://whiteboard.openoffice.org/doc/index.html 
 


