
Introduction to Mac OS X

Course Description

Mac OS X is the exciting new operating system that is now installed on all new Cal Poly
faculty/staff Macintosh workstations.  Although, without a doubt, Mac OS X is a stunning
technical achievement, it is quite a change from Mac OS 9.  This course will examine the
elements of the desktop, dock, and toolbars; setting system preferences (e.g., personal
settings, hardware settings, internet settings, printer preferences, etc.); using the Classic OS 9
side of OS X; setting up user accounts; file sharing; basic troubleshooting techniques and more.

OS X Desktop and the Dock

Most of what you do on your Mac begins on the Desktop.  The Desktop allows you to manage
files, store documents, launch programs, adjust the way your Mac works, and much more!  The
first icon you will probably notice on your Desktop is the hard drive icon (usually labeled as
Macintosh HD, iMac HD, or something like that).  The hard drive icon resides in the upper-right
corner of your Desktop and by double-clicking upon it, you can view the files and applications
on your hard drive.

Figure 1:  Mac OS X Desktop and Dock

At the bottom of the OS X Desktop, you will see a row of icons.  These icons comprise the
“Dock.”  Single-clicking a dock icon allows you to either 1) Open applications, files, or folders;
or 2) Bring an open application, file, or folder to the front of all others.  Whenever you launch a
program, Mac OS X puts its icon in the Dock – marked with a little black triangle.  As soon as
you quit the program, its icon disappears from the Dock unless you had placed the application
in the Dock permanently. If you realize the application is one that you use a lot and would like
to keep it in the Dock permanently, simply press and hold down your mouse on the Dock icon
and select “Keep in Dock” and an alias is made.
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Pressing and holding your mouse (or Control-Clicking) on a folder that resides in the Dock
allows you to see the contents of an entire folder as well as other folders embedded within the
folder.  You can also put away files by dragging them directly into the Dock’s folder icons just
as if it were a regular folder on the hard drive.

By default, the Dock contains a number of commonly used Mac OS X applications.  However,
you can add your own preferences of applications, folder, and files to the Dock by simply
dragging an application, file, or folder icon directly to the Dock.  OS X automatically creates an
alias in the Dock but keeps the application, file, or folder in its original location.  To get rid of
the alias, simply drag the alias from the Dock into the Trash (Note:  The Trash icon also resides
on the Dock).  Disposing of the alias does not affect the original application, file, or folder.

S   UGGESTIONS OF    I   TEMS TO    P   LACE IN THE     D    OCK  :

v Your Mac Hard Drive:  Many Mac fans immediately drag their hard drive icon onto the
right side of the dock.  Now you have quick access to every single file and application on
your computer.

v The Applications Folder:  For quick access to any program on your machine.
v The Documents Folder: Quick access to one of the primary folders in OS X.
v System Preferences:  Quick access to your system preferences folder.
v Important Utilities:  Stuffit Expander, DropStuff, DropZip
v The Print Center:  Found in Applications > Utilities allows you to view the printer

status
v URLs:  Drag important URLs from your browser window into the Dock or create a folder

with URLs in it and place the folder on the Dock for quick reference.

The Apple Menu

The Apple Menu contains items that were previously in the Special menu of OS 9.  Notice that
this is where you access Sleep, Restart… and Shut Down…   System Preferences… (previously
known as the Control Panel in OS 9) also resides in the Apple Menu.

Figure 2:  The Apple Menu

If an application seems to be “hanging,” you may Force Quit the application by pressing
Command + Option+ Esc or select Force Quit… from the Apple menu.
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On the Apple menu you will also find the command for Log Out; this is a new command in OS
X.    Since OS X is a multi-user operating system, you can have multiple users at one Mac.  This
command allows you to switch users without restarting or shutting down the Mac.

You may also access the Dock Preferences in the Apple menu where you can control the size
of the Dock, turning on or off magnification, the position of the Dock on the screen, and other
effects.

Figure 3:  Dock Preferences

Where’s the Finder?

Can’t find the Finder?  In Mac OS X the Finder is at the top LEFT of the Desktop rather than the
top RIGHT as it was in OS 9.  Select File>New Finder Window or Command+N (Note: In OS 9,
Command + N generated a new folder; New Folder is now Shift+Command+N.)

Figure 4:  The Finder File Menu

An examination of the Finder File Menu will reveal a few changes from OS 9.  For example, the
keyboard command to make an alias is no longer Command + M; the command has been
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changed to Command + L.  To move an item to the trash, select the item (i.e., click on a
document you wish to trash so its icon is highlighted) and use the keyboard command of
Command + Delete (Backspace). Note:  You may later empty the trash by selecting Shift +
Command + Delete if you are in the Finder at the time or you may also simply choose Empty
Trash… from the Finder menu.

Figure 5:  The Finder Menu

Notice also that in order to hide the Finder, you may simply select the keyboard command
Command + H.  This is an excellent command to memorize for it will hide almost any
application that is at the forefront in OS X (one exception to this is Adobe PhotoShop 7.0 for OS
X; it’s command for hiding is Control + Command + H because Command + H was already in
use for viewing Extras in PhotoShop).

Please review the various buttons and functions in the Finder window below.

Figure 6:  New Finder Window

Take a moment to experiment with the Close, Minimize, and Zoom buttons in the top left
corner of the New Finder Window.  Note that the Minimize button will shrink the window and
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place it in the right side of your dock for later use until you close the window completely.  Apple
refers to this unusual effect as the “Genie Effect” and you may turn it off, if you wish, in the
Dock Preferences (Apple Menu > Dock > Dock Preferences…) (Note:  Holding Shift while
clicking on the Minimize button will cause this genie effect to occur in slow motion… those
Apple OS X developers had too much time on their hands!)

Click on the view buttons to choose between Icon, List, or Column views.

Figure 7:  View Buttons

Column view is a new view for Mac OS X.  It allows you to navigate much more easily through
depths of folders to find your document or application.  To resize a column in column view, just

drag the column size icon  that appears at the bottom of a column underneath the vertical
scroll bar arrows.  Dragging the column size icon will resize all of the columns at once to the
same size.  If you wish to just resize one column, use the command Option + drag on the
column size icon.

To select the view options for Icon, List or Column View, select Show View Options…
(Command + J)  from the View window in the Finder.  The View Options window is dynamic; in
other words, the choices change based upon which view you have chosen (i.e., Icon, List, or
Column).

Figure 8:  The Finder’s View Menu

You may customize the toolbar that appears at the top of the Finder window by going to the
Finder’s View menu and selecting Customize Toolbar…

Figure 9:  Customize Toolbar
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Drag items up into the Toolbar from this customized palette to permanently place items in
your Toolbar.  Drag them out of the Toolbar of your Finder window to eliminate them.

From the Finder’s Finder menu, select Preferences… to set up your Finder’s preferences.

Figure 10:  Finder Preferences

Folder Structure in Mac OS X

The folder structure is slightly different in Mac OS X:

1. The Computer folder at the top level of the folder hierarchy shows all the storage
devices (Hard Drives, CD- or DVD-ROM, Zip Disks, Firewire Drives, etc.) that are
currently connected to your Mac.

2. You may have noticed that you have TWO applications folders available on your Mac OS
X Hard Drive:  Applications (this one is for OS X Applications) and Applications Mac OS
9.

3. You also have TWO system folders:  System (this is the OS X System Folder) and the
System Folder (this is the OS 9 System Folder).

4. The Home Folder (Shift + Command + H) is the most important folder to you as a user!
I strongly recommend that you store all the files that you create or work with in one of
the folders of your Home folder, whether in your Documents folder or in a new folder
that you create.  If you do this, you find it much easier to back-up your important data -
- for it will all reside in the Home folder (even your preferences will be preserved since
they are stored in the User>Library folder.

5. The Home folder contains Movies, Pictures and Music folders where you may stash
your multimedia files.  You may add your own folders and subfolders to your Home
folder as you see fit.  You may also add aliases to favorite folders, files, and servers to
your Favorites folder by using Command + T.  The Favorites folder resides in your
Home folder > Library > Favorites which you may access by using Shift + Command
+ F or by using the selections in the Go menu of the Finder (see Figure 11 below).
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Figure 11:  Finder Go Menu

6. In Mac OS X, you have TWO Desktops:  Desktop (OS 9) and the Desktop that resides in
the Users > Home folder (named according to user).  Due to the multi-user system of
OS X, every user has their own Desktop configuration with their own personal settings,
screen saver, etc.  In previous versions of Mac OS, the Desktop folder resided at the root
level of the Mac and was invisible (i.e., items stored on the Desktop appeared there and
the folder containing them was hidden from view unless you were using File Sharing to
connect remotely to a Mac.)  In Mac OS X, each user has their own Desktop, and the
items there are stored in the user’s Desktop folder.

7. You will find that you have TWO different Library folders on your hard drive:  one at the
root level of your OS X disk and another in your Home folder.  The Library folder at the
root level is like a public library – it stores items that everyone with access to this Mac
can use.   The Library in your Home folder is like the library in your own house (i.e., it is
personalized for your individual use.)  For example, the Library folder at the root level
contains the Fonts folder that holds all the fonts installed on your Mac and these fonts
are available to ALL users of your Mac; fonts stored in the Fonts folder of the user’s
Library folder are exclusive and can only be used by that individual user.  (Actually,
there is a third Library folder residing in the System folder but you should never touch
this folder… just leave it alone… it is the nerve center of your Mac and should NEVER be
moved, removed, or renamed!)

8. The Shared folder (residing within the Users folder) allows everyone who uses the Mac
to use the files stored there.  If you want other people who have an account on your Mac
to have access to a file or folder, this is the place to stash it. However, the Shared folder
is not available to guests.  For guest access, use the Public folder.

9. The Public folder is where you may place files that you want to be accessible to
everyone with an account as well as guests logged in remotely via LAN or the Internet.
For example, if Bob wants to share a file with Linda, he can put it in the Public folder
under Linda’s user account; or, if he wants to be sure that no one but Linda is able to
see it, Bob can place it in Linda’s Drop Box folder within her Public folder.  The
privileges to do all of this are set up when the user accounts are created and you don’t
have to do any changes to user privileges in the accounts to make them accessible in
this manner.
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Mac OS 9 Classic Mode

Since OS X has an OS 9 emulator, all of your OS 9 software can still be used on your Mac.  When
you launch an older OS 9 application, it’s as if you’ve booted a computer within your computer;
that is, Classic will emulate the startup process and load everything needed to mimic OS 9 and
run the application.  When you open a Classic application, the application’s icon appears on the
Dock and disappears when you quit the application.

If you wish, you may set your System Preferences to start up Classic upon Login by selecting
System Preferences > Classic > Start/Stop Tab and then selecting the checkbox next to Start
up Classic on login to this computer.  The advantage to doing this is that you won’t have to
wait a minute or two for Classic to launch the first time you launch a Classic application;
however, the disadvantage is that Classic uses a hefty amount of RAM and other system
resources.  We don’t recommend you do this.

You may also boot your Mac so it runs from OS 9 instead of from OS X.  Some programs (mostly
games and Quark) will not work when you try to run them in Classic mode under OS X.  When
that happens and you really want to use that program, you’ll have to start up your Mac with OS
9.  To do this, follow the instructions below:

1. Open System Preferences by clicking its icon on the Dock or choosing System
Preferences from the Apple menu.

2. Click the Startup Disk icon to open the Startup Disk pane.
3. Click the Mac OS 9 icon to select it.
4. Restart your Mac by choosing Restart from the Apple menu or clicking the Restart

button.

That’s all there is to it!  When your Mac comes back to life, you’ll be running Mac OS 9.

When you are finished using Mac OS 9 and you want to run Mac OS X again, you must use the
Startup Disk in the Control Panel of OS 9:

1. Open the Startup Disk control panel by choosing Control Panels > Startup Disk from
the Apple menu on the OS 9 side.

2. Click the Mac OS X icon.
3. Click the Restart button in the Startup Disk window.

That’s all there is to it!  In a few moments, you’ll be back and running in Mac OS X.

Setting Up a Printer for the First Time with OS X

This is so easy!  Finally a printer setup that makes sense!  Follow these steps to set up a printer
for the first time:

1. After you connect your computer and printer with a compatible cable, provide a power
source for your printer, and install the software for your printer, configure your printer
by opening the Print Center application in the Utilities folder within your Applications
folder (i.e., Applications > Utilities > Print Center). Even if a printer is connected to
your Mac or is available via a network, your Mac doesn’t know it exists until you use the
Add Printer command to create an access path to it.

2. Click the Add button at the bottom right of the Print Center window.
3. The Printer List window will appear; this is where you choose the kind of connection

you have to your printer (e.g., USB port, Network, or AppleTalk).
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4. In the Add Printer window, click the Directory Services pop-up menu.  Note:  Many
USB printers (such as most of the compatible printers from Epson, Canon, Hewlett-
Packard) will be recognized immediately without you having to perform step 5.

5. From this menu, choose the type of printer connection (AppleTalk, USB, Network) that
you have so that you can find the printer that you wish to use.

6. After you choose your printer connection type, you will see the names and kinds of
available printers in the Printer List window.

7. Click the name of the printer that you want from the list and then click the Add button.
The window will close and the Printer List window will appear, containing the printer you
just added.  If you’ve added printers before, they appear here too.

8. If you have trouble setting up a printer for Mac OS X, you may want to contact your
printer’s manufacturer and get the latest printer driver for your printer.

9. Open your application and choose Page Setup and make the choices you desire.  Then
select File > Print… to print your document.  Note:  In the Page Setup window or in the
Print window, you may select form the pop-up menu exactly which printer you wish to
print to; however, remember that you can only print to the printers you have already set
up previously in the Print Center.

Converting a File into PDF Format

One of the beautiful features of Mac OS X is that you can easily change any document to PDF
(portable document format) that can be read by anyone who downloads and installs Adobe
Acrobat Reader.  When you distribute your file in PDF format to other people, they see precisely
the same fonts, colors, page design, etc. that you did in your original document even if they
don’t have the fonts or software you used to create the document.  When you create a PDF file,
you can distribute it (by email, for example) without even having to think about what kind of
computers your correspondents are using!

You may create a PDF file by using one of three different methods:

v Method 1:  The File >Save as PDF method
Not all programs offer a File>Save as PDF command but the ones that do give you by
far the easiest method of creating a PDF file.  If this option is available in your software,
a Save dialog box appears and all you have to do is type the name of the file and save it!

v Method 2:  The Preview Method
The standard Print dialog box offers a Preview button.  When you click it, your printout-
to-be opens up in Preview program.  From here, just choose File > Save as PDF.

v Method 3:  The Save as File Method
You can also choose File >Print.  In the Print dialog box, choose Output Options from
the unnamed pop-up menu.  Turn on Save as File, choose PDF from the Format menu,
and add the .pdf extension to the file name.  Then, just click Save.

Note:  Although PDF is the best file format to secure that another user sees the document in the
same way that you do, in certain situations the document the other person sees and prints may
not always be 100 percent identical to the original.  This is because the currently selected
printer on your machine can affect things like letter spacing and margins, etc.  Thus, if an inkjet
printer was selected in your Print Center at the time you created the PDF, the layout may be
slightly different when printed on a laser printer.  The only thing you can do to try to prevent
this problem is to anticipate the kind of printer your audience will use when printing.
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File Sharing

With File Sharing turned on, you can summon the icon for a folder or disk attached to another
computer on the network.  Upon success of connection, the icon for the other computer will
show up on your Desktop underneath your own hard drive.  After you have this icon, you simply
double-click on it to open it and drag files back and forth exactly as though the other Mac’s
folder or disk is a giant CD you have inserted into your own machine.

The instructions below assume that you have already wired the network together.  The first
thing you must do when preparing for file sharing is to set up an account (i.e., a name,
password, and Home folder) for each person that you wish to allow to visit your computer.
Important:  The name and password you use to login when you sit down in front of the
computer are the same name and password you need to connect over the network.

Once you have established accounts for everyone you wish to acces your Mac, even if it’s only
you, you’re ready to proceed.

1. Open System Preferences.
2. Click the Sharing icon.
3. The Sharing panel will appear.  In the Computer Name text box, type a name for the

computer.  Your Mac will appear on the network with this name so make it descriptive.
4. Click the Start button near the top of the dialog box.  (This takes a moment; when File

Sharing is finally on, the button will say Stop).  Close the window.
5. Repeat this process on each Mac OS X computer in your office, giving each one a

different computer name.

Figure 12:  File Sharing Window

Note:  Setting up a Mac that running Mac OS 8.5 through Mac OS 9 follows almost exactly the
same steps but the dialog boxes are different and File Sharing is found within the Control
Panel.  When you go through this process on earlier OS systems, be sure to turn on Apple Talk.
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Now, to connect to another Mac from Mac OS X:

1. Choose Go > Connect to Server (Command + K)
2. Click Local Network (Note:  After the first time of connecting you can just click on the

“At” pop-up menu at the top of the dialog box and it will display a list of Recent Servers
you have accessed before.  Also, if you know the IP address of the Mac you’re trying to
access you can just type the IP address using the Apple File Protocol; for example,
typing something like afp://192.168.1.2).  At Cal Poly, you will see several Network
icons representing different areas of the university.  Click the appropriate area you
desire to access.

3. In the second column, you should now see a list of every Mac for which you turned on
File Sharing.

4. Double-click the name of the Mac you wish to access.
5. A Connect to the file server window will appear for you to input your user name and

password.

Figure 13:  Connect to Server Window

6. Type your short user name, press Tab, and type your password.  (Remember:  Type
precisely what you would use to log into the networked computer if you were sitting in
front of it.  If you aren’t sure what your user name is, open your System Preferences
and your home-base Mac, click Users, click on your name, and then click Edit to find
out what your short user name is.)
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Figure 14:  Connect to Server Login

7. If no one has set up an account for you on that machine, you may click Guest for limited
access to what’s on that Mac.  If the Guest button is dimmed, then someone has turned
off the Guest access altogether and you are out of luck! (Turn on/off Guest access by
going to System Preferences > Sharing >Services tab and clicking on Personal File
Sharing).  If you are allowed Guest access, you may put items into anyone’s Drop Box
folder but you can’t open it; however, you may open anything that the person has
placed in their Public folder.  The rest of the Mac is invisible and off-limits to you.

8. Click Connect or press the Return key.  A list of disks and folders on that Mac that have
been shared for network access will appear.

9. Double-click the name of the disk or folder you want to open.  An icon for the disk or
folder will be mounted on your Desktop.

NOTE:  If you wish to access a Mac OS X machine from Mac OS 9 you need to use the Chooser.

To disconnect yourself from a shared disk or folder, simply drag it to the trash.  If you want to
disconnect others who are file sharing on your Mac, you may slam the door by just turning off
the File Sharing feature!

Connecting to Shared Disks and Folders on Windows PCs (SMB)

This is one of the coolest features of Mac OS X:  it can see shared disks and folders on Windows
PC machines  (no longer are you an outsider if you are the only person in your office using a
Mac!).   Here’s how it works:

1. On the Windows PC, share a folder (usually you do this by right-clicking on a folder,
choosing Properties from the shortcut menu, clicking the Sharing tab, and turning on
Share this folder on the network.  In the Share name text box, type a name (no spaces
allowed) for the folder as it will appear on the network.)

2. On the Mac, choose Go >Connect to Server (Command + K).
3. The Connect to Server dialog box will appear.
4. Type smb:// followed by the Windows machine’s name or IP address.  Add a slash (/)

and then type the name of the shared folder.  (For example:  smb://Dell4100/drafts or
smb://192.168.1.45/documents  (Note:  To find out a PC’s network name, right-click
on the My Computer icon and then right-click a blank spot in the window.  Choose
Properties from the shortcut menu.  In the resulting box, click Computer Name.
Capitalization counts here; you want the Full Computer Name, NOT the Computer
Description.  To find out the PC’s IP, go to the Control Panel on the PC and select
Network Connections.  Right-click the Local Area Connection icon and choose
Properties from its shortcut menu.  Double-click on the Internet Protocol (TCP/IP) and
the resulting window will show the PC’s IP address.)

5. Click Connect
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6. Type your name and password, if necessary, and then click OK.  If you have an account
on the Windows PC, use that name and password.  If a PC administrator administrates
the PC, you may be able to leave the password blank and still get in.

7. The shared folder from the Windows machine will appear as an icon on your Desktop.

Review the System Preferences

The hub of Mac customization is System Preferences (what used to be known as the Control
Panel).  To really know your Mac well, take time to review the options that you may customize
in System Preferences:

Personal:
a. Desktop
b. Dock
c. General
d. International
e. Login Items
f. My Account
g. Screen Effects

Hardware:
a. CDs and DVDs
b. Color Sync
c. Displays
d. Energy Saver
e. Keyboard
f. Mouse
g. Sound

Internet & Network:

a. Internet
b. Network (Locations and DHCP)
c. QuickTime
d. Sharing

System:

a. Accounts
b. Classic
c. Date and Time
d. Software Update
e. Speech
f. Startup Disk Universal Access

Congratulations!  You have embarked on a new journey of enjoying your computer more fully
by installing and configuring Mac OS X.  Now, go have a great time!


