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Introduction 
This document has been developed to provide you with information about accessibility 

and Microsoft Excel 2010. In this document, you will learn about the tools available for 

accessibility. You will also learn how to control the visual appearance of your 

spreadsheet. Additionally, best practices and effective spreadsheet structure are also 

covered to help you when using Excel. 

Objectives 
The following learning objectives for accessibility will be covered in this document: 

 The available tools

 How to use the keyboard to work with ribbon programs

 Controlling the visual appearance of the spreadsheet

 Best practices for spreadsheet design

 Effective spreadsheet structure

 How to use the accessibility checker

 How to obtain help
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Tools 
The following explains how various tools can be used effectively for accessibility with 

Microsoft Excel 2010. 

AutoCorrect 

The AutoCorrect feature in Excel 2010 is a list of words that are frequently misspelled 

and mistyped. This feature corrects these words when a person enters them into a 

document. The words can be added and deleted from the list. This is a great tool for 

accessibility. 

This tool can also be used for abbreviation expansion. For example, suppose that you 

frequently type Atlanta, Georgia, but would like to enter an abbreviation into 

AutoCorrect so that fewer keystrokes are required for entry. The following explains 

how to use the AutoCorrect tool for abbreviation expansion: 

1. Click the File tab (see Figure 1).

2. Click the Options button (see Figure 2).

Figure 1 – File tab 

Figure 2 – Options button 
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3. Click the Proofing button (see Figure 3). 

 

 
 

 

4. Click the AutoCorrect Options button (see Figure 4). 

 

 
 

Figure 3 – Proofing button 

Figure 4 – AutoCorrect Options button 
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5. In the Replace box (see Figure 5), enter an abbreviation for Atlanta, Georgia. For 

example, you could enter xAGA (the x stands for expand). 

 

 
 

 

6. In the With box, enter Atlanta,Georgia (see Figure 6). 

 

 
 

 

Figure 5 – Autocorrect  

Figure 6 – Autocorrect 
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7. Click the Add button (see Figure 7). 

 

 
 

 

8. Click the OK button (see Figure 8). 

 

 
 

 

When xAGA is typed into Excel, the words Atlanta, Georgia, will appear on the screen. 

This abbreviation expansion could also be used for phrases, sentences, and paragraphs. 

  

Figure 7 – Autocorrect 

Figure 8 – Autocorrect 
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Comments 

Comments are another tool that can be used for accessibility. Comments can be inserted 

in a spreadsheet to help improve the contents. The following instructions explain how 

to insert a comment. 

 

1. Place your cursor in the cell where the comment will be inserted. 

2. Click the Review tab (see Figure 9). 

 

 
 

 

3. Then, click New Comment (see Figure 10). 

 

 
 

 

4. Enter a comment in the box that appears (see Figure 11).  

 

 
 

 

To remove a comment, right-click on the cell containing the comment and then select 

Delete Comment. 

 

Figure 9 – Review Tab 

Figure 10 – New Comment Button 

Figure 11 – Comment Bubble 

Comment 

Box 
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Spelling 

The spelling feature in Excel 2010 allows you to double-check the spelling to strengthen 

your spreadsheet. To start the spelling feature, follow the steps below. 

 

1. Click the Review tab (see Figure 12). 

 

 
 

 

2. Click the Spelling button (see Figure 13). 

 

 
 

 

3. The Spelling feature will start and give you the option to accept or reject the 

suggestions offered. 

 

Thesaurus  

The thesaurus is a great tool to improve the vocabulary used within the spreadsheet. To 

display the thesaurus, follow the instructions listed below. 

 

1. Place the cursor on the target word. 

2. Click the Review tab (see Figure 14). 

 

 
 

 

 

Figure 12 – Review Tab 

Figure 13 – Spelling 

Figure 14 – Review Tab 
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3. In the Proofing area, click Thesaurus (see Figure 15). 

 

 
 

 

4. A window will appear on the screen showing other potential words that could be 

used in the place of the selected word (see Figure 16). 

 

 
 

 

Templates 

The template feature is another great tool for accessibility. Templates allow the user to 

have a spreadsheet available that has been customized with items such as name, date, 

etc. The background color, font style, font color, text size, etc. can be customized for the 

user as well. To create a template, follow the instructions below. 

 

1. Open a spreadsheet. 

2. Enter any necessary text in the spreadsheet as desired. 

3. Apply settings to the spreadsheet, such as background color, text size, etc. 

 

 

Figure 15 – Thesaurus 

Figure 16 – Thesaurus 
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4. Click the File tab (see Figure 17).  

 

 
 

 

5. Click Save As (see Figure 18). 

 
 

 

6. In the Save As dialogue box, enter the filename. Then, for Save as type, select Excel 

Template (see Figure 19). 

 
 

 

7. Click the Save button. 

 

Figure 17 – File Tab 

Figure 18 – Save As 

Figure 19 – Save As 
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Using the Keyboard to Work with Ribbon Programs 

Some users may prefer using the keyboard as they work with Microsoft Excel. Access 

Keys allow you to control each button on the ribbon with the keyboard. The following 

instructions explain how to use Access Keys. 

 

1. Press and release the Alt key on the keyboard. 

2. You will see letters and numbers appear next to the buttons on the ribbon (see 

Figure 20).  

 

 
 

 

3. Press the number or letter of your choice. If you select a letter for one of the tabs on 

the ribbon, the tab will become selected and you will see a letter or number for each 

command on the selected tab.  

4. Continue to press letters or numbers until you accomplish your goal. If a window 

opens in Excel, use the tab key to move the cursor throughout the window. The 

space bar will allow you to place a check-mark in the check boxes that are available. 

 

 

 

 

 

 

 

 

 

 

Figure 20 – Letters and Numbers on the Ribbon  
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Controlling the Visual Appearance of your Spreadsheet 
Excel 2010 has many features available to control the visual appearance of your 

document, which can help with accessibility.  

 

Highlight Tool 

The highlight tool allows you to draw attention to a certain part of the spreadsheet. The 

highlight tool can be found on the Home tab in the Font category (see Figure 21). 

 

 
 

 

Fonts 

You can determine what font you want included within your spreadsheet. The active 

font may be changed on the Home tab in the Font category (see Figure 22).   

 

 
 

 

The following fonts are considered easy to read: Arial, Verdana, and Helvetica. Fonts that 

are bold make the words appear larger. The Bold button is found on the Home tab in the 

Font category. 

 

Font Color 

This tool gives you the ability to change the color of your text. You will find this tool on 

the Home tab in the Font category (see Figure 23). 

 

 
 

Figure 21 – Highlight Tool  

Figure 22 – Fonts  

Figure 23 – Font Color  
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Cell Spacing 

Cell spacing will increase/decrease the amount of space within a cell. The following 

instructions explain how to adjust the size of the cell. 

 

1. To increase/decrease the height of the cell, allow your mouse pointer to hover 

between the numbers on the left side of the spreadsheet so that it appears as a 

double-arrow (see Figure 24). 

 

 
 

 

2. Hold the mouse button down and move the mouse up or down. This will change the 

height of the cell. 

3. To increase/decrease the width of the cell, allow your mouse pointer to hover 

between the letters on the top of the spreadsheet so that it appears as a  

double-arrow (see Figure 25). 

 

 
 

 

 

4. Hold the mouse button down and move the mouse to the left or right. This will 

adjust the width of the cell. 

Figure 24 – Cell Spacing  

Figure 25 – Cell Spacing  
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Zoom 

The Zoom tool magnifies the spreadsheet on the screen. However, this will not change 

the appearance of the spreadsheet when it is printed. The tool can be found on the View 

tab in the Zoom category (see Figure 26). 

 

 
 

 

Zoom to Selection 

The Zoom to Selection button can help to improve accessibility for users by increasing the 

size of text on the screen. The following steps explain how to use this feature. 

 

1. Select a cell on the spreadsheet. 

2. Click the Zoom to Selection button (see Figure 27). 

 

 
 

 

 

3. The spreadsheet will zoom to the selected cell. 

4. To return to the normal view, click the button labeled 100% (see Figure 28). 

 

 
 

 

 

 

 

 

Figure 26 – Zoom 

Figure 27 – Zoom to Selection 

Figure 28 – 100% Button 
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Best Practices 
The following should always be considered when developing a spreadsheet to make it 

accessible to everyone. 

 

Page Layout 

Place the data on a spreadsheet so that it appears tightly connected together. It is best to 

avoid spacing data on the spreadsheet with blank cells, blank rows, and blank columns. 

 

Alternate Text (alt text) 

Be certain to use alt text for your graphics so that those with visual impairments will be 

able to understand the purpose of the graphics in the document. 

 

To add alt text to a graphic in Excel, follow the instructions below. 

1. Right-click the graphic. 

2. Select Format Picture. 

3. In the window that appears, click Alt Text. 

4. Enter your title and description. 

5. Click the Close button. 

 

Remember the following when developing alt text. 

 Use concise wording (do not exceed 100 characters). 

 Avoid sentences and capitalize only the first letter. 

 Avoid punctuation. 

 Avoid bold or italicized formatting. 

 

Font Size and Color Schemes 

Remember the following when developing spreadsheets so that they will be accessible. 

 Make all font sizes at least ten points. 

 Avoid using light or pale font colors with light backgrounds within a cell. 

 Limit the use of the following font variations: bold, italics, and capital letters. 

 

Spreadsheet Structure 
The following explains how to better structure your spreadsheet for accessibility. 

 

Headings 

When developing the spreadsheet, be certain to use descriptive headings for rows and 

columns. Also, use headings for different sections of data on the spreadsheets. This will 

help people with screen readers to quickly and easily understand each section of the 

spreadsheet without having to read the details in each section. 
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Hyperlinks 

When inserting a hyperlink in a spreadsheet, the hyperlink will be more effective if the 

user sees a descriptive title for the URL. For example, if you have a link to Kennesaw 

State University in your spreadsheet, it would be more effective to use Kennesaw State 

University instead of non-descriptive text such as, Click Here. 

  

In Microsoft Excel, the hyperlink button is found on the Insert tab in the Links category 

(see Figure 29).  

 

 
 

 

Graphs and Charts 

Users of screen readers will not be able to see graphs and charts created with Excel. 

Consider providing tables with words and numbers as an alternative. 

 

When including a graph and/or chart on the spreadsheet, be certain that it is effectively 

labeled. 

 

Highlighting 

Highlight important areas of the spreadsheet to help users see these sections quickly 

and easily. 

 

Sorting 

Often, it can be effective to sort data within the spreadsheet. The following explains 

how to sort. 

 

1. Select the data to be sorted don’t select the column headings . 

2. On the Data tab, click the Sort button (see Figure 30). 

 

 

 

Figure 29 – Hyperlink button 

Figure 30 – Sort button 
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3. In the Sort window that appears, select the column to be sorted. Then, select the 

order to be used for sorting (see Figure 31).  

 

 
 

 
4. Click OK to sort the data. 

 
Worksheets 

To make worksheets more accessible, it is important to give each sheet a meaningful 

name (the default names are Sheet1, Sheet2, and Sheet3). In Figure 32, the worksheets 

have been renamed Monday, Tuesday, and Wednesday. 

 

 
 

Figure 31 – Sort 

Figure 32 – Worksheets 
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The following instructions explain how to rename the worksheet(s): 

 

1. Allow your mouse pointer to hover over the tab (Worksheet1, Worksheet2, Worksheet3, 

etc.). 

2. Right-click the mouse and select Rename from the menu that appears. 

3. The tab will become selected. Type the new name for the tab (example: Monday). 

4. Press the Enter key on the keyboard. 

 

Accessibility Checker 
The accessibility checker will scan your spreadsheet to check for potential accessibility 

problems. The following explains how to use this tool: 

 

1. Click the File tab. Then, click the Check for Issues button (see Figure 33). 

 

 
 

 

2. Then, select Check Accessibility. 

3. A report will be created for you containing a list of possible accessibility issues 

within your spreadsheet. 

 

 

 

 

 

 

Figure 33 – Accessibility Checker 
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Getting Help 

If you need additional help, you may contact the KSU Service Desk by phone or email 

at the following:  

FACULTY/STAFF: 4 0‐578‐ 999 - service@kennesaw.edu  

STUDENTS: 470-578-3555 - studenthelpdesk@kennesaw.edu 

UITS Outreach & Distance Learning Technologies Training 

Team Email: uitstechout@kennesaw.edu 

Twitter: http://www.twitter.com/odlt 

Website: http://uits.kennesaw.edu/techoutreach  

mailto:service@kennesaw.edu
mailto:studenthelpdesk@kennesaw.edu
mailto:tstechout@kennesaw.edu
http://www.twitter.com/odlt
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