
Microsoft Office Excel 2013 
Advanced Excel Tools 

Training, Outreach, Learning Technologies and Video Production

University Information Technology Services 



   

     

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Copyright © 2014 KSU Department of University Information Technology Services  

This document may be downloaded, printed, or copied for educational use without further permission of the 

University Information Technology Services Department (UITS), provided the content is not modified and this 

statement is not removed. Any use not stated above requires the written consent of the UITS Department. 

The distribution of a copy of this document via the Internet or other electronic medium without the written 

permission of the KSU - UITS Department is expressly prohibited. 

 

Published by Kennesaw State University – UITS 2014 

The publisher makes no warranties as to the accuracy of the material contained in this document and 

therefore is not responsible for any damages or liabilities incurred from UITS use. 



   

     

 

University Information Technology Services 
 

Microsoft Office Excel 2013 

Advanced Excel Tools 

 

Table of Contents 

Introduction ............................................................................................................................................................ 4 

Learning Objectives ................................................................................................................................................. 4 

Creating Nested Functions ...................................................................................................................................... 5 

Linking Data ............................................................................................................................................................. 5 

Macros .................................................................................................................................................................... 7 

Enabling the Developer tab ................................................................................................................................ 7 

Recording a Macro .............................................................................................................................................. 8 

Managing your Macros ................................................................................................................................. 12 

Moving Spreadsheets ........................................................................................................................................... 13 

Copying Spreadsheets ....................................................................................................................................... 15 

Hiding Rows and Columns .................................................................................................................................... 16 

Hiding Spreadsheets ......................................................................................................................................... 16 

Unhiding Rows and Columns ................................................................................................................................ 17 

Unhide Spreadsheets ........................................................................................................................................ 17 

Protecting your Spreadsheets ............................................................................................................................... 18 

Preparing your Cells .......................................................................................................................................... 19 

Locking your Spreadsheet ................................................................................................................................. 20 

Unprotect Worksheets .................................................................................................................................. 21 

Protecting Workbooks ...................................................................................................................................... 22 

Unprotect Workbooks .................................................................................................................................. 23 

Creating Templates ............................................................................................................................................... 23 

Using a Template .............................................................................................................................................. 25 

Additional Help ..................................................................................................................................................... 26 

 



Revised 8/23/2014  Page 4 of 26 

Introduction 

This booklet is the companion document to the Excel 2013: Advanced Excel Tools workshop. The 

booklet will explain how to create a simple macro, how to use nested formulas, how to create 

templates, hide/unhide rows and columns, and protect/unprotect your spreadsheets and workbook. 

 

 

Learning Objectives 

After completing the instructions in this booklet, you will be able to: 

 Understand what Nested Functions are 

 Link data between sheets 

 Understand what Macros are 

 Create a simple Macro 

 Hide/unhide information in your spreadsheet 

 Protect your spreadsheet and workbook 

 Create templates out of workbooks 
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Creating Nested Functions 

Nested functions are functions within a function. For example, by nesting an IF function within an 

existing IF function, you can test additional conditions.  

 

For example: =IF(F2>=75,"Pass",IF(F2>=65,"Conditional","Fail")) 

 

This formula checks the cell for a value, and if it is greater than or equal to (>=) a predetermined grade 

(e.g. 75), then the formula will return the phrase Pass (Note: Pass is in quotes to indicate to Excel that 

this is the value we want returned, and it is not another function). If the number in the cell is less than 

75, Excel will move to the next part of the formula, and so on.  

 

This can be helpful if you want to assign scores or grades based on certain conditions (See Figure 1).  

 

 
Figure 1 - Nestled IF Function 

 

Linking Data  

Linking data between spreadsheets allows you to reference data contained elsewhere in your 

workbook without having to copy all of the information. For example, you could have a workbook that 

has multiple spreadsheets tracking regional sales and a separate spreadsheet to tally the totals across 

all regions. By linking to the regional data from the totals, you will only have to update your 

information in one location. The following explains how to link data between spreadsheets:  

  

1. Open the spreadsheet that contains the source data and the target location (e.g. Eastern 

Region, Totals).    

 

2. Select the cell(s) in the source spreadsheet that contain the data that you want to link to the 

target location (See Figure 2). 

 

 
Figure 2 - Selected Cells 
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3. Right-click on the selected cells.  

 

4. A context sensitive menu will appear. Click on Copy (See Figure 3). 

 

 
Figure 3 - Copy 

5. Go to the target location and select the cell(s) where you want to paste the source data  

(See Figure 4). 

 

 
Figure 4 - Paste Location 

6. Right-click on the selected cells.  

 

7. A context sensitive menu will appear. Click on the Paste Link icon (See Figure 5).  

 

 
Figure 5 - Paste Link 

8. The target location will now be updated whenever the source data is changed. 
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Macros  

Macros are programs that run within Excel that can help to automate common repetitive tasks, thus 

saving time and boosting productivity with a simple click or command. For example, if you want to 

delete a row within your spreadsheet, you will need to select the row, click the home tab, select 

delete, and then click delete rows. Instead, you can create a macro that completes the entire sequence 

with a single click or keystroke.  

 

Enabling the Developer tab 

Before you can record a macro, you will need access to the Developer tab in the Ribbon. The following 

steps explain how to add the Developer tab to the Ribbon: 

 

1. Right-click in an empty section within the Ribbon. 

 

2. A dialog box will appear. Select Custo ize the Ribbo … (See Figure 6). 

 

 
Figure 6 - Customize the Ribbon 

3. The Customize Ribbon window will appear, with options to customize the ribbon on the right 

(See Figure 7).  

 

 
Figure 7 - Customize the Ribbon Options 
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4. Click on the checkbox next to Developer (See Figure 8). 

 

 
Figure 8 - Developer Checkbox 

5. Click on OK.  

 

6. The Developer Tab will now be displayed in the Ribbon (See Figure 9). 

 
Figure 9 - Developer Tab 

  

Recording a Macro  

When recording your macro, Excel will register every mouse-click and keystroke as part of your macro 

until you stop recording. The following example describes how to create a simple macro that will 

delete an entire row.  

 

Note: If the Developer tab is not available, see the section on Enabling the Developer tab on how to 

activate it.  

 

1. In the Ribbon, click on the Developer tab (See Figure 10).  

 
Figure 10 - Developer Tab 
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2. In the Code group, click on Use Relative References (See Figure 11). 

 

 
Figure 11 - Use Relative References 

Note: With Use Relative References enabled, macros are recorded with actions relative to the initial 

selected cell. 

 

3. In the Code group, click on Record Macro (See Figure 12).  

 

 
Figure 12 - Record Macro  

4. The Record Macro window will appear (See Figure 13).  

 

 
Figure 13 - Record Macro Window   

5. Type in a name in the Macro Name field (See Figure 13).  

  

6. In the Shortcut key field, enter a shortcut key (This will be the keyboard command you use to 

activate your Macro) (See Figure 13).  
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7. In the Store macro in: field, click the down arrow, and select where you want the macro to be 

stored (if you plan to use a macro with more than one workbook, select the Personal Macro 

Workbook option) (See Figure 13).  

 

8. Enter a description of the macro in the Description field (See Figure 13). 

 

9. Click on OK to begin recording.  

 

10. You are ready to record the steps of the macro (See Figure 14). 

 

 
Figure 14 - Stop Recording 

Note: When recording your macro, Excel will register every mouse-click and keystroke as part of your 

macro until you stop recording. 

 

11. In your spreadsheet, select a row you wish to delete. 

 

12.  In the Ribbon, click on the Home tab (See Figure 15). 

 
Figure 15 - Home Tab 

13. Under the Cells grouping, click on the arrow below delete (See Figure 16).  

 

 
Figure 16 – Delete 
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14. From the dropdown, click on Delete Sheet Rows (See Figure 17).  

 

 
Figure 17 - Delete Sheet Rows 

15. The selected row will be deleted.  

 

16. Click on the Developer tab (See Figure 18).  

 
Figure 18 - Developer Tab 

17. On the Developer tab, click on Stop Recording (See Figure 19). 

 

 
Figure 19 - Stop Recording  

18. To run your DeleteRows macro, select the row to delete and press CTRL + r.  
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Managing your Macros  

Once you have created a macro, you can run it without using the keyboard shortcut, delete it, edit it, 

or change the keyboard options for it.  

 

1. In the Ribbon, click on the Developer tab (See Figure 20). 

 
Figure 20 - Developer Tab 

2. In the Code group, click on Macros (See Figure 21). 

 

 
Figure 21 – Macros 

3. The Macro window will open. A list of available macros will be displayed (See Figure 22).  

 

 
Figure 22 - Macro Window 
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A. To run a macro, select it from the list, and click Run (See Figure 22).  

 

B. To edit a macro in Visual Basic, select it from the list, and click on Edit (See Figure 22). 

 

Note: You will need to understand Visual Basic in order to edit the macro. If you need to make a 

correction and are not familiar with Visual Basic, it would be easier to delete the macro and re-record 

it. 

C. To delete a macro, select it from the list, and click on Delete (See Figure 22).  

 

D. To change the shortcut key or description for the macro, select it from the list, and click 

on Optio s…(See Figure 22). 

 

4. Click on Cancel when finished.  

 

Moving Spreadsheets  

The following explains how to move spreadsheets:  

  

1. Left-click and hold on the spreadsheet tab at the bottom of your spreadsheet (See Figure 23).  

 

 
Figure 23 - Spreadsheet Tab 

2. Drag the spreadsheet tab in-between any existing spreadsheet to move. Your cursor will 

change to show you are moving a spreadsheet (See Figure 24).  

 

 
Figure 24 - Dragging Spreadsheet 

3. Release the left-mouse button to finish moving your spreadsheet.  

 

-OR- 

 

1. Right-click on the spreadsheet tab you wish to move.  
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2. A context sensitive menu will appear. Click on Move or Copy… (See Figure 25). 

 

 
Figure 25 - Move or Copy... 

3. The Move or Copy window will appear. Under Before sheet, select where you want the currently 

selected spreadsheet to be moved (See Figure 26).  

 

 
Figure 26 - Move or Copy Window 

4. Click on OK. The spreadsheet will be moved before the selected location.  
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Copying Spreadsheets 

The following explains how to copy spreadsheets: 

 

1. Right-click on the spreadsheet tab you wish to copy.  

 

2. A context sensitive menu will appear. Click on Move or Copy… (See Figure 27). 

 

 
Figure 27 - Move or Copy... 

3. The Move or Copy window will appear. Under Before sheet, select where you want the copy of 

the currently selected spreadsheet to be moved (See Figure 28).  

 

 
Figure 28 - Move or Copy Window 

4. Next to Create a Copy, click on the checkbox. 

 

5. Click on OK. A copy of the spreadsheet will be made in the selected location. 
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Hiding Rows and Columns 

Hiding rows and/or columns in your spreadsheet can hide them from view so you can focus on other 

parts of your table. To hide a row or column: 

  

1. Select the row/column in your spreadsheet.  

 

2. Right-click on the selected row/column.  

 

3. A context sensitive menu will appear. Click on Hide (See Figure 29).  

 

 
Figure 29 - Hide 

4. The selected row/column will be hidden.  

 

Hiding Spreadsheets 

You can also hide whole spreadsheets if needed. To hide a spreadsheet: 

 

1. Right-click on the spreadsheet tab.  

 

2.  A context sensitive menu will appear. Click on Hide (See Figure 30).  

 

 
Figure 30 - Hide Spreadsheet 

3. The selected spreadsheet will be hidden.  
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Unhiding Rows and Columns 

To identify hidden rows/columns in your spreadsheet, pay attention to the numbering (rows) or 

lettering (columns). If they appear to skip within their sequence, then rows/columns are hidden. To 

unhide rows and columns: 

 

1. Select the rows/columns surrounding the hidden rows/columns (See Figure 31).  

 

 
Figure 31 - Select Hidden Rows/Columns 

2. Right-click on the selected row/column.  

 

3. A context sensitive menu will appear. Click on Unhide (See Figure 32).  

 

 
Figure 32 – Unhide 

4. The hidden rows/columns will now be visible.  

 

Unhide Spreadsheets 

The following shows how to unhide spreadsheets: 

 

1. Right-click on a spreadsheet tab.  

 

2. A context sensitive menu will appear. Click on Unhide (See Figure 33). 

 

 
Figure 33 - Unhide Spreadsheet 
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3. The Unhide window will appear. Select a spreadsheet to unhide from the list (See Figure 34).  

 

 
Figure 34 - Unhide Window 

4. Click on Ok.  

 

5. The spreadsheet will now be visible.  

 

Note: If you right-click on a spreadsheet tab, and Unhide is greyed out, then your workbook contains 

no hidden spreadsheets.  

 

Protecting your Spreadsheets 

Protecting your spreadsheet can limit what cells other users can select, and even what types of edits 

are allowed. This feature is helpful if you have created a spreadsheet with complex formulas that you 

do not want to be deleted, or if you just want to limit where users can enter information (e.g. an 

inventory spreadsheet which asks users to fill in specific sections).  You can choose to 

protect/unprotect specific cells in your spreadsheet, or lock an entire spreadsheet. 

 

By default, Excel assumes that you will want to lock all cells in your spreadsheet. If you wish users to be 

able to edit specific cells, you will first need to prepare the cells so they can be edited while the rest of 

your spreadsheet is locked.  
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Preparing your Cells  

Before locking your spreadsheet, you will need to unlock the cells that you want users to be able to 

edit (e.g. you have a quarterly sales spreadsheet with formulas in the totals column. You want users to 

enter values for their quarter, but let Excel calculate the totals):  

  

1. Select the cells that you want to enable users to edit (See Figure 35). 

 

 
Figure 35 - Selected Cells to Unlock 

2. Right-click on the selected cells.  

 

3. A context sensitive menu will appear. Click on For at Cells… (See Figure 36). 

 

 
Figure 36 - Format Cells... 

4. The Format Cells window will appear. Click on the Protection tab (See Figure 37).  

 
Figure 37 - Protection Tab 
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5. Uncheck the checkbox next to Locked.  This will allow users to make changes to your selected 

cells.  

 

6. Click on OK. 

 

7. You will need to lock your spreadsheet to enable protection (See Locking your Spreadsheet). 

 

Locking your Spreadsheet 

Once you have designated which cells will remain unlocked (See Preparing your Cells), you can protect 

the spreadsheet to lock the rest of your cells (e.g. cells that contain necessary formulas or instructions 

for users). 

 

1. In the Ribbon, click on the Review tab (See Figure 38).  

 
Figure 38 - Review Tab 

2. In the Changes grouping, click on Protect Sheet (See Figure 39). 

 

 
Figure 39 - Protect Sheet 

3. The Protect Sheet window will appear. Click the checkbox next to Protect worksheet and 

contents of locked cell (See Figure 40). 

 

 
Figure 40 - Protect Sheet Window 
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4. Enter a password if desired. You will be asked to confirm your password if you create one.  

 

Note: Without a password, anyone can easily unprotect the sheet. If you forget your password, it 

cannot be retrieved, so make sure to write it down and keep it in a safe place. 

 

5. Next to Select locked cells, uncheck the checkbox.  

 

Note: Make sure the checkbox next to Select unlocked cells is checked. This will enable users to access 

and make changes to unlocked cells.  

 

6. Click on Ok.  

 

7. Your spreadsheet will be protected. Only the unlocked cells will be selectable. 

 

Unprotect Worksheets 

The following explains how to unprotect a worksheet that has been locked for editing: 

 

1. In the Ribbon, click on the File tab (See Figure 41).  

 
Figure 41 - File Tab 

2. The Backstage View will appear, and the protect workbook information will display any 

spreadsheets that are currently locked.  

 

3. Click on Unprotect next to the spreadsheet you want to unprotect (See Figure 42).  

 

 
Figure 42 - Unprotect Spreadsheet 

4. If the spreadsheet is password protected, you will be prompted to enter the password, then 

click ok.  

 

5. The selected spreadsheet has been unlocked and is ready to be edited.  
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Protecting Workbooks  

You can protect an entire workbook to prevent unwanted changes such as moving, deleting, or adding 

sheets. Do the following to protect a workbook:  

 

1. In the Ribbon, click on the Review tab (See Figure 43).  

 
Figure 43 - Review Tab 

2. In the Changes grouping, click on Protect Workbook (See Figure 44). 

 

 
Figure 44 - Protect Workbook 

3. The Protect Structure and Windows window will appear. Make sure that the checkbox next to 

Structure is checked (See Figure 45). 

 

 
Figure 45 - Protect Structure and Windows 

4. Enter a password if desired. You will be asked to confirm your password if you create one.  

 

Note: Without a password, anyone can easily unprotect the workbook. If you forget your password, it 

cannot be retrieved, so make sure to write it down and keep it in a safe place. 

 

5. Click on Ok. Your workbook will be protected. 
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Unprotect Workbooks 

The following explains how to unprotect a protected workbook: 

 

The following explains how to unprotect a worksheet that has been locked for editing: 

 

1. In the Ribbon, click on the Review tab (See Figure 46).  

 
Figure 46 - Review Tab 

2. In the Changes grouping, click on Protect Workbook (See Figure 47).  

 

 
Figure 47 - Unprotecting Workbook 

Note: If the workbook is currently protected, the protect workbook icon will be highlighted in green.  

 

3. If the spreadsheet is password protected, you will be prompted to enter the password, then 

click ok.  

 

Creating Templates  

The sample below shows a template for calculating first quarter sales for a company. This template 

was created by modifying an existing spreadsheet and saving it as a template file. The template could 

also have been created from a new spreadsheet, with the formulas for totals saved in the proper cells.  

 

 
Figure 48 - Template Example 
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To prepare a spreadsheet as a template: 

 

1. Create your spreadsheet as normal (e.g. formatting, headers, formulas for calculating totals, 

etc.) 

 

2. In the Ribbon, click on the File tab (See Figure 49).  

 
Figure 49 - File Tab 

 

3. The Backstage View will appear. Click on Save As (See Figure 50). 

 

 
Figure 50 - Save As 

4. Select a location to save the document and click on Browse.  

 

5. Enter a name for the template in the File name: field.  

 

6. In the Save as type field, select Excel Macro-Enabled Template (See Figure 51). 

 

 
Figure 51 - Excel Macro-Enabled Template 

Note: By default, Excel will save your template in the My Documents/Custom Office Templates folder.  

 

7. Click on Save.  

 

8. Your template will be saved.  
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Using a Template 

The following explains how to access the custom-made template created in the Creating Templates 

section. 

 

Note: The following instructions show how to access templates saved to the default My 

Documents/Custom Office Templates.  

 

1. In the Ribbon, click on the File tab (See Figure 52).  

 
Figure 52- File Tab 

2. The Backstage View will appear. Click on New (See Figure 53). 

 

 
Figure 53 - New 

3. Click on Custom to access your custom templates (See Figure 54). 

 

 
Figure 54 - Custom Templates 
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4. Click on Custom Office Templates (See Figure 55).  

 

 
Figure 55 - Custom Office Templates 

5. Click on your desired template.  

 

Additional Help  

For additional help or installation issues, please contact the KSU Service Desk (Faculty & Staff) or the 

KSU Student Help Desk (Students). 

 

KSU Service Desk for Faculty & Staff 

 Phone:  470-578-6999 

 Email:   service@kennesaw.edu 

 Website:  http://uits.kennesaw.edu/faculty-staff/ 

KSU Student Help Desk 

 Phone:  470-578-3555 

 Email:   studenthelpdesk@kennesaw.edu 

 Website:  http://uits.kennesaw.edu/students/ 

mailto:service@kennesaw.edu
http://uits.kennesaw.edu/faculty-staff/
mailto:studenthelpdesk@kennesaw.edu
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