
   

     

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Creating Web Pages with a Template 
Adobe Dreamweaver Creative Cloud 2014 

  

Training, Outreach, Learning Technologies & Video Production 

  

University Information Technology Services 



   

     

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Copyright © 2015 KSU Division of University Information Technology Services  

This document may be downloaded, printed, or copied for educational use without further permission of the 

University Information Technology Services Division (UITS), provided the content is not modified and this 

statement is not removed.  Any use not stated above requires the written consent of the UITS Division.  The 

distribution of a copy of this document via the Internet or other electronic medium without the written 

permission of the KSU - UITS Division is expressly prohibited. 

 

Published by Kennesaw State University – UITS 2015 

The publisher makes no warranties as to the accuracy of the material contained in this document and 

therefore is not responsible for any damages or liabilities incurred from UITS use. 



   

     

University Information Technology Services 
 

Creating Web Pages with a Template 

Adobe Dreamweaver Creative Cloud 2014 

 

Table of Contents 

Introduction ............................................................................................................................................................ 5 

Learning Objectives ................................................................................................................................................. 6 

Terms and Definitions ............................................................................................................................................. 7 

File Name Conventions ........................................................................................................................................... 8 

Create a Local Folder .............................................................................................................................................. 8 

Web Servers ............................................................................................................................................................ 9 

The Dreamweaver Environment ............................................................................................................................. 9 

Document Toolbar ............................................................................................................................................ 10 

Panels ................................................................................................................................................................ 11 

Defining a Site ....................................................................................................................................................... 12 

To Define a Site ................................................................................................................................................. 12 

To Define the Remote Server............................................................................................................................ 13 

Connecting to Server ............................................................................................................................................ 18 

Designing Your Site ............................................................................................................................................... 19 

Creating the Template .......................................................................................................................................... 21 

Adding a Table .................................................................................................................................................. 22 

Adding CSS Styles .............................................................................................................................................. 24 

Site Header CSS ............................................................................................................................................. 24 

Background Color .......................................................................................................................................... 27 

Site Footer CSS .............................................................................................................................................. 29 

Site Navigation Links CSS .............................................................................................................................. 31 

Site Body Text CSS ......................................................................................................................................... 34 

Editable Region ................................................................................................................................................. 36 

Save the Template Page .................................................................................................................................... 37 

Creating a New Web Page From a Template ........................................................................................................ 37 



   

     

Adding Images to a Web Page .............................................................................................................................. 40 

Inserting an Image ............................................................................................................................................ 40 

Image Tag Accessibility Attributes .................................................................................................................... 41 

Resize the Image ............................................................................................................................................... 41 

Adding Hyperlinks to a Web Page ......................................................................................................................... 42 

Creating Internal Hyperlinks ............................................................................................................................. 42 

Creating External Hyperlinks ............................................................................................................................. 43 

Save the Hyperlinks ........................................................................................................................................... 44 

Adding Anchor Links to a Web Page ..................................................................................................................... 45 

Publishing Your Website ....................................................................................................................................... 46 

Compare the Content ....................................................................................................................................... 48 

Viewing Your Website ........................................................................................................................................... 49 

Reconnecting From Another Location .................................................................................................................. 49 

Backing Up Your Site Definition ............................................................................................................................ 50 

To Back Up The Site Definition ......................................................................................................................... 50 

To Restore The Site Definition .......................................................................................................................... 52 

Resources .............................................................................................................................................................. 54 

Additional Help ..................................................................................................................................................... 54 

 

 



Revised 3/9/2015  Page 5 of 54 

Introduction 

The purpose of this booklet is to help students, faculty, and staff understand the process involved with 

creating and publishing web pages using Dreamweaver CC 2014 and templates. 

 

Note to Students: Every student has access to web space on the Students server if the 

student has an active NetID. The NetID is the same as your Owl Express login. You must 

have an active NetID before you can publish a web page to the Students server. If you do 

not have an active NetID, or have forgotten the password, you can go to 

https://netid.kennesaw.edu for assistance. 

 

Note to Faculty/Staff: If you are faculty or staff, you will need an account on the ksuweb 

server. If you do not have an account on the ksuweb server, you can apply for an account at 

http://its.kennesaw.edu/forms/account_setup_form.html. 

 

Caution: In this workshop you will be creating a website in your account on either the studentweb 

server or the ksuweb server. If you have an existing website on this account, it will be overwritten. If 

you do not want to overwrite the existing site, once you have defined your site, you can create a 

subfolder in your account and put your website files there. 

 

Creating: When creating and editing a web page using Dreamweaver, you are editing files that are on 

the computer in front of you. This computer is referred to as the local computer. You should create a 

folder on this local computer and keep all of the files related to your website (pages, images, etc.) in 

this local folder. In Dreamweaver, you look at the files in your local folder with the local view. 

 

Publishing: When you are finished editing the files that make up your website, you will need to send 

these files to your account on the web server. This computer is referred to as the remote computer. 

The action of sending these files is called publishing to the server, FTPing the files, or uploading the 

files to the server.  Drea ea er alls this a tio  Put . In Dreamweaver, you view the files on the web 

server with the remote view. 

 

Viewing: After publishing (putting) your web page files to your account on the web server, you will 

want to check and see if they are working properly. To view your website, open a web browser and 

enter your web address in the address bar. 

 

 Your web address on the Students server is http://studentweb.kennesaw.edu/~yournetid 

 Your web address on the Faculty/Staff ksuweb server is 

http://ksuweb.kennesaw.edu/~username 

 

Note: Do not put any sensitive information on your website; even if there are no links to it from 

another web page.  

https://netid.kennesaw.edu/
http://its.kennesaw.edu/forms/account_setup_form.html
http://studentweb.kennesaw.edu/~yournetid
http://ksuweb.kennesaw.edu/~username
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Learning Objectives 

After completing the instructions in this booklet, you will be able to: 

 Understand terms and definitions of web spaces 

 Define a site 

 Learn how to create a template and web pages from a template 

 Setting up a table 

 Create and apply CSS styles 

 Insert and adjust images 

 Create internal and external hyperlinks 

 Publish your website to a web server 
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Terms and Definitions 

Web page - a web page is a document file just like a text file. It can be edited with Notepad, WordPad, 

or any text editor. The main difference between a web page and a regular text file is that a web page is 

formatted with HTML tags. This HTML formatting is what you see when you switch your web page from 

the Design view to the Code view.  

 

Website - a website is a collection of web pages that are usually linked together with hyperlinks. 

 

Hyperlink or Link - a section of text or image that appears colored and/or underlined on a web page 

that, when clicked, will take you to another web page. 

 

HTML - a hypertext markup language consisting of tags. HTML tells the web browser how to display the 

content of your web page. 

 

Web server - a computer or host for your website that makes your site publicly available on the web.  

If you are a student at KSU and have activated your NetID (https://netid.kennesaw.edu), you have web 

space on the Students server http://studentweb.kennesaw.edu. If you are faculty/staff, you can apply 

for web space on the http://ksuweb.kennesaw.edu server. 

 

Web browser - an application or program that is installed on your computer that allows you to view 

web pages on the Internet (i.e. Internet Explorer, Mozilla Firefox, Google Chrome, Apple Safari). 

 

Index page - The index page is the main page of your website, also called homepage. This is the first 

page that people will see when they visit your site. When you create the index page you must save it as 

index.html. 

Note: index.html must be spelled with all lower case letters. 

 

Put, Publish, or FTP- To send or upload your web page or pages to your account on the web server. 

 

Web address - a URL (Uniform Resource Locator) is the text you type into the address bar of your web 

browser to access a web page. For example: http://www.cnn.com. Your web address on the Students 

server is http://studentweb.kennesaw.edu/~yournetID. The our etID  i  this address refers to our 
username for the student email system, Owl Express, etc.  

Note: Do not put www in this address. If you are faculty/staff, your address will be 

http://ksuweb.kennesaw.edu/~username. The ~ symbol (a.k.a. tilde) means home account.  

 

Template - Dreamweaver allows you to save a webpage as a template. You can add editable regions to 

the template. Then you create web pages from the template. When you edit the template and save the 

changes, Dreamweaver updates all of the pages that are created from the template. Anything that you 

add to the template appears on every web page that is created from that template.  

https://netid.kennesaw.edu/
http://studentweb.kennesaw.edu/
http://ksuweb.kennesaw.edu/
http://www.cnn.com/
http://studentweb.kennesaw.edu/~yournetID
http://ksuweb.kennesaw.edu/~username
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File Name Conventions 

When naming your files, always use lowercase letters and avoid using spaces. For example, if building a 

page for course o er ie s it ould e est to a e the file course_overview.html  or 
courseoverview.html  i stead of Course Overview.html .  The reason for this is that the 

Kennesaw.edu server is based on a UNIX platform – what this means for you is that all files are case-

sensitive. If ou ha e a file a ed Course Overview.html  i  our site a d a user t pes i  course 

overview.html  the file WILL NOT come up. 

 

The rules for file naming are: 

 Avoid uppercase letters 

 No spaces 

 Separate words with hyphens or underscores 

 Main page is i de .ht l  

 Use shorter names 

 No special characters such as question marks, exclamation points, dollar signs, symbols, etc. 

 No punctuation 

 Do not use numbers as the initial character 

 

Create a Local Folder 

It is a good practice to create a local folder before you get started with Dreamweaver. This is your 

working directory. Dreamweaver refers to this folder as your local site. The local folder is usually a 

folder on your hard drive.  

 

1. To create a local folder, Right-click on your Desktop, and then click on New > Folder (See Figure 

1). 

 

 
Figure 1 - Create a Local Folder. 

2. Gi e our e  folder a a e; so ethi g like M  We site .  
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Web Servers 

There are five items that you will need to know before you can publish web pages to a web server, 

even if it is your personal space on your home ISP account, such as AT&T, or Comcast. 

 

 Items that you need to know to publish to a web server: 

1. Server Name - We will be using the Students server or the ksuweb server, so this will be 

studentweb.kennesaw.edu or ksuweb.kennesaw.edu. 

2. Connection protocol - SFTP. 

3. Username - This is your NetID.  

4. Password - This will be the password for your NetID or the password for your ksuweb 

account. 

Note: that your ksuweb account password is different than your NetID password. 

5. Root directory - For the Students server and the ksuweb server, this will be html/.  For 

some web servers, this may be public_html, or just public. 

 

The Dreamweaver Environment 

Dreamweaver is an application that helps you to create, edit, and manage web pages and websites. 

Dreamweaver provides you with a WYSIWYG (what you see is what you get) editing environment. In 

other words, while editing your page, it looks like it will when viewed by a web browser. It also lets you 

easily switch over to see and edit the HTML code of your web page if you so desire. Dreamweaver also 

provides a publishing tool that helps you easily manage your files both locally and on your web server 

(See Figure 2). 

 

 
Figure 2 - Dreamweaver Environment.  
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Document Toolbar 

The Document toolbar allows you to access different views, preview your pages in a browser, title your 

page, and upload files (See Figure 3). 

 

 
Figure 3 - Document Toolbar. 

There are three working views: Code, Split, and Design. 

 The Code view shows any source code for the page. 

 The Design view shows the WYSIWYG page. 

 The Split view displays both the code and the design views on the screen. 

 

Other elements of the document toolbar are the Live view, the Earth  utto , a d the Title dialog box. 

 The Live view displays a rendered view of how the page would like in a browser. 

 The Earth  utto  ill sho  a pre ie  of the page i  a  a tual ro ser. 

 The Title dialog box allows you to add a title to the page. This title will show at the top of 

browsers. 
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Panels 

Panels are sections of Dreamweaver that help you monitor and modify your work. 

 

The four panels that we will use the most are the Properties panel, the Files panel, the Insert panel, and 

the CSS Designer panel (See Figure 4). 

1. The Properties panel will show you all of the properties that can be set for the item(s) that are 

selected (See Figure 4). 

2. The Files pa el ill allo  ou to easil  ope  our lo al files for editi g, a d the  Put  or Get  
your files to and from the server (See Figure 4). 

3. The Insert panel lets you insert objects, such as images, tables, and media files (See Figure 4). 

Note: To expand or minimize a panel: double-click on its tab. To turn off or on the panels press 

F4. 

4. The CSS Designer panel is a CSS Property Inspector that lets you visually create CSS styles, files, 

and set properties, along with media queries (See Figure 4). 

 

 
Figure 4 - Panels. 
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Defining a Site 

You must define a site for each new website you create. A site in Dreamweaver is a collection of files 

and folders (web pages, images, etc.) on your personal computer, and a link to your web space on the 

Internet. As you create and edit your web pages, you will be working on files on this local site. When 

your pages are finished and ready to be viewed on the Internet, Dreamweaver gives you the ability to 

Put” these files from your local site onto your web space (remote server). 

 

Note: You should create a local folder for your web pages and have access to an account on a web 

server before you can define a Site. 

 

To Define a Site 

1. Start Adobe Dreamweaver CC 2014. 

2. Click on Site > New Site… from the Menu bar (See Figure 5). This opens the Site Setup window. 

 

 
Figure 5 - New Site. 

3. Enter a name for your site in the Site Name field (See Figure 6). 

Note: The Site Name is used only for identifying the site within Dreamweaver so choose a name 

that will help you recognize the site later. 

4. Click on the folder icon next to the Local Site Folder text box (See Figure 6). 

 

 
Figure 6 - Site Setup.  
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5. Use the File dialog to navigate to your local folder and then click on Select Folder. 

6. Verify that your local folder appears in the Local Site Folder text box (See Figure 7). 

 

 
Figure 7 - Local Site Folder. 

Note: To be able to publish your files to the web, you must enter the remote server 

information. You do not need to complete the next steps to begin working on your 

Dreamweaver site. You only need to define a remote server when you want to connect to the 

web and publish your pages. If you ready to begin working on your site, click on the Save 

button. 

 

To Define the Remote Server 

1. Select Servers from the left side menu (See Figure 8). 

 

 
Figure 8 - Servers Menu. 

2. Click on the + sign icon at the bottom-left corner of the blank text area to Add new Server (See 

Figure 9). 

 

 
Figure 9 - Add new Server.  
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3. A pop-up dialog with the Basic tab selected appears (See Figure 10). 

 

 
Figure 10 - Basic Tab of the Add Server Dialog Box. 

4. Provide a Server Name. 

Note: The Server Name is only used within Dreamweaver so you should provide a name that is 

meaningful to you. 

5. Select SFTP from the Connect using: drop-down menu (See Figure 11). 

Note: “FTP  sta ds for Secure File Transfer Protocol. 

 

.  
Figure 11 - Connect using SFTP.  
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6. Type in the SFTP Address.  

 The SFTP Address for students is studentweb.kennesaw.edu. 

 The SFTP Address for faculty and staff is ksuweb.kennesaw.edu. 

7. Enter your Username and Password. 

 The Username and Password for students is their NetID and their NetID password. 

 The Username and Password for faculty and staff is their NetID and their ksuweb 

password. 

 

Note: When you enter a password, Dreamweaver automatically checks the Save Password box 

below the password field. Unchecking the option deletes your password. If you are a student 

using a computer in one of the campus labs, be sure to un-check the Save Password check box 

so that other students using the computer you are sitting at will not have access to your web 

space. If you are faculty/staff, and are using the computer in your office, you may want to leave 

this box checked. If you un-check this box, Dreamweaver will ask you for your password every 

time you try to access your site. 

 

Your password must be entered in order to test your connection. So enter it now. Later, after 

you have successfully tested your connection, make sure to uncheck the Save (password) 

option if you are on a lab computer.  

 

8. Enter html/ in the Root Directory text box. 

Note: It is important that this be exactly as shown, or else it may not work properly. The Root 

Directory is the actual folder on the server where your site will reside. 

9. You can test the connection by clicking on the Test button. 

a. If you get a message saying that Dreamweaver connected successfully, click OK (See 

Figure 12). 

 

 
Figure 12 - Successful Connection Test. 
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b. If you get an error message, click OK (See Figure 13), and then repeat steps 5 through 9 

to verify that the information was entered correctly. 

Note: The server information is case sensitive. If you still cannot successfully connect to 

the server, contact the KSU Service Desk for assistance. 

 

 
Figure 13 - Connection Test Error Example. 

10. Enter your website address in the Web URL: text box (See Figure 14).  

a. The Web URL for students is http://studentweb.kennesaw.edu/~yournetid 

b. The Web URL for faculty and staff is http://ksuweb.kennesaw.edu/~yournetid 

 

 
Figure 14 - Server Definition. 

11. Click on the Save button.  

http://studentweb.kennesaw.edu/~yournetid
http://ksuweb.kennesaw.edu/~yournetid


  Page 17 of 54 

12. The server now appears on the Servers list (See Figure 15). 

 

 
Figure 15 - Servers. 

a. If you need to make changes to the server definition, you may click on the pencil icon 

below the text box (See Figure 16). 

 

 
Figure 16 - Edit Existing Server. 

13. Click the Save button.  
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Connecting to Server 

1. To see your site and all of the files that it contains, go to the Files panel (See Figure 17). 

a. You should to see your new site in the left drop-down menu (See Figure 17). 

b. The right drop-down menu allows you to toggle the local view and remote server, as 

well as offering a few more advanced views (See Figure 17). 

 

 
Figure 17 - Views Drop Down Menu in Files Panel. 

Note: The different view options are: 

 Local view: Shows the copies of the files for your website which are located on 

your local machine. 

 Remote server: Shows the copies of the files for your website which are stored 

on the Internet server that is providing access to your site to users. 

 Testing server: An advanced feature which would show the files which are being 

stored on a test server (We do not use this feature). 

 Repository view: Shows a listing of all the files in the repository when working 

with Subversion, a versioning control system. (We do not use this feature). 

 

2. To see your remote files, click on the Connect to Remote Server button in the Files panel, and 

then select Remote server from the views drop-down menu (See Figure 18). 

Note: if you see an index.html file on the remote server, it is just a placeholder. You will be 

replacing it with your own custom home page. 

 

 
Figure 18 - Connect to Remote Server.  
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3. Select Local view from the views drop-down menu to display the local site again. 

Note: If you are working at a computer that does not have the local folder with your website 

files in it, you can create a local folder, define the site on this computer, and then download the 

files from your account on the server, by clicking on the Get arrow (See Figure 19). 

 

 
Figure 19 - Get Files from Server. 

Designing Your Site 

It is always a good idea to take a little time to think about your website design before creating the first 

page. Design work will save time, especially if you anticipate a large site with many pages.  

 

A good design practice is to have each page of the site have some common elements such as images, 

colors, borders, and navigation tools. This design philosophy results in the existence of two types of 

elements, elements that are on every page of a website (common elements), and elements that are on 

only on one web page of a website (unique elements). This design philosophy is the foundation of the 

template. 

 

When designing a website with a template, you place elements that will appear on every page of a 

website on the template, and you place elements that appear only on one page of a website on a web 

page created from the template. Any web pages created from a template will inherit common 

elements from the template. 

 

Another consideration is layout; in other words, where will the common elements be placed on the 

pages, and where will the unique elements be placed. The common elements should be on the 

template, and the unique elements should be on each individual page. 
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In this case, we will use a table with three rows and three columns, similar to the one below (See 

Figure 20). 

 

 

Common Elements 

 

Common Elements Unique Elements 

 

 

Common Elements 

 

Figure 20 - Template Table. 
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Creating the Template 

A template is a common structure of a website that is used by most web pages. Once a template has 

been created, you can create new web pages based on that template. All of the pages created from a 

template will have everything that is on the template plus whatever you add to that particular page. 

Additionally, whenever a change is made to the template, such as the addition of a new image or 

navigation link, these pages will be updated automatically. 

 

Note: Remember, only the elements that are common to all web pages in our website should be on the 

template. Do not put unique content on this page. 

Note: You can have multiple templates for your website. For example, large websites, such as one for a 

university, may have different templates for each department or section of the institution. 

 

1. To create the template, Go to the File menu, and choose New…., the New Document window 

appears (See Figure 21). 

2. Select Blank Page (See Figure 21). 

3. Select HTML template in the Page Type: column (See Figure 21). 

4. Select <none> in the Layout: column (See Figure 21). 

5. Click the Create button (See Figure 21). 

 

 
Figure 21 - New Blank HTML Template.  
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6. Type in a Title for your template (See Figure 22). This title will be inherited by each page that is 

created from this template. 

 

 
Figure 22 - Template Title. 

Adding a Table 

1. Insert a table by going to the Insert menu, and selecting Table (See Figure 23). 

 

 
Figure 23 - Insert Table. 

2. Build the table. 

a. Use 3 Rows by 3 Columns (See Figure 24). 

b. Set the Table width to 100 percent (See Figure 24). 

c. Set the Border thickness, Cell padding, and Cell spacing all to zero (See Figure 24). 

d. Click the OK button (See Figure 24). 

 

 
Figure 24 - Table Properties.  
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3. The table appears on the Design view (See Figure 25). 

 

 
Figure 25 - Table. 

4. Expand the table to fill the page with a header, footer, a right margin, and a left margin, 

according to our design (See Figure 27), by dragging the dotted lines (See Figure 26). 

Note: The height of the table may be set to about 900 pixels. 

 

 
Figure 26 - Expanding Rows and Columns. 

 
Figure 27 - Expanded Table.  
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5. You can select the table by clicking in one of the cells of the table and then going to Modify > 

Table > Select Table. Once you select the table, the Properties panel changes to show the 

properties of the table (See Figure 28). 

 

 
Figure 28 - Table Properties. 

6. Change the table Align from Default to Center (See Figure 29). 

 

 
Figure 29 - Table Align. 

Adding CSS Styles 

We are going to define the properties such as text font, background image and color, and the 

appearance of its elements using the CSS (Cascading Style Sheet) Designer panel. 

 

Site Header CSS 

1. Insert text into the header of your page by clicking in the top center cell of your table (See 

Figure 30).  

 

 
Figure 30 - Header Text. 
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2. The properties panel changes from table to text properties (See Figure 31). Remember, the text 

you enter will appear at the top of every page created from this template.  

 

 
Figure 31 - Text Properties. 

3. Select CSS button on the Properties panel (See Figure 32). The CSS properties appear. 

 

 
Figure 32 - CSS Properties. 

4. Click the CSS Designer button (See Figure 33). This will open the CSS Designer panel if not 

already open. 

 

 
Figure 33 - CSS Designer Button. 

5. Click on the + sign to add a new Source in the CSS Designer panel (See Figure 34). 

6. Click Define in Page (See Figure 34). 

 

 
Figure 34 - Add CSS Source.  
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7. Click on the + sign to add a Selector in the CSS Designer panel (See Figure 35). 

8. Enter a name for the selector. In our example, the name is .Site_Header (See Figure 35). 

 

 
Figure 35 - Add CSS Selector. 

9. From the Properties in the CSS Designer panel, we are going to set the following (See Figure 36). 

a. Click on the Text button. 

b. Choose your color for your text. 

c. Click on font-family to select a font. 

d. Click on font-style to select a style. 

e. Click on font-weight to select a weight. 

f. Click on font-size and select a size. 

g. Specify your text-align to select your alignment. 

h. Click on the Background button. 

i. Choose your background-color. 

 

  
Figure 36 - CSS Formatting for Site_Header.  
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10. Click in the top center cell of your table where you typed your text. 

11. On the Properties Panel, click on the Targeted Rule drop-down and select Site_Header (See 

Figure 37). 

 

 
Figure 37 - Applying CSS Site_Header. 

12. The header is now formatted based on the new CSS formatting (See Figure 38). 

 

 
Figure 38 - Formatted Text for Header. 

Background Color 

Change the background color of the cells in the table by clicking in each cell of the table and using the 

Bg color palette on the Cell Properties panel (See Figure 39). 

 

 
Figure 39 - Bg Color Palette. 
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Note: If the Cell Properties panel does not appear below the text properties panel when you click on a 

cell, expand the properties pane by clicking on the arrow pointer in the lower right corner of the 

properties panel (See Figure 40). 

 

 
Figure 40 - Expand to See Cell Properties Panel. 

1. Place your cursor in the cell for which background color needs to match the header 

background. 

2. Click on the Bg color palette (See Figure 39). 

3. Click on the Dropper button, the mouse cursor turns into a dropper (See Figure 41).  

 

 
Figure 41 - Bg Color Palette Dropper. 

4. Cli k o  the a kgrou d of the header’s ell. 
5. Press Enter on your keyboard. 

6. The background is applied to the other cell (See Figure 42). 

7. Repeat steps 1 through 6 for the other cells except the center cell of the 2nd row. 

8. For the center cell of the 2nd row, make it a lighter shade of yellow (See Figure 42). 

 

 
Figure 42 - Cell Background Color. 
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Site Footer CSS 

1. Insert text as a footer at the bottom of the page. This footer will appear at the bottom of every 

page that is created from this template. 

a. On the bottom row of the table, click in the left cell and remove the height in the 

Properties Panel if one was set (See Figure 43). 

b. Insert text at the bottom of the page. This footer will appear at the bottom of every 

page that is created from this template (See Figure 43). 

Note: the copyright symbol (©) used in the footer was obtained from the menu Insert > 

Character > Copyright. 

 

 
Figure 43 - Footer. 

2. Create a new CSS selector to format the footer. Click on <style> for Source in the CSS Designer 

panel (See Figure 44). 

 

 
Figure 44 - Click on <style> to Create a Footer Style. 

3. Click on the + sign to add a Selector in the CSS Designer panel (See Figure 45). 

4. Enter a name for the selector. In our example, the name is .Site_Footer (See Figure 45). 

 

 
Figure 45 - Add CSS Selector Site_Footer. 
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5. From the Properties in the CSS Designer panel, we are going to set the following (See Figure 46). 

a. Click on the Text button. 

b. Choose your color for your text. 

c. Click on font-family to select a font. 

d. Click on font-style to select a style. 

e. Click on font-weight to select a weight. 

f. Click on font-size and select a size. 

g. Specify your text-align to select your alignment. 

h. Click on the Background button. 

i. Choose your background-color. 

 

  
Figure 46 - CSS Formatting for Site_Footer. 

6. Click in the bottom left cell of your table where you typed your text. 

7. On the Properties Panel, click on the Targeted Rule drop-down and select Site_Footer (See 

Figure 47). 

 

 
Figure 47 - Applying CSS Site_Footer. 
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8. Repeat previous steps 6 and 7 on the bottom center and bottom right cells (See Figure 48). 

 

 
Figure 48 - Formatted Text for Footer. 

Site Navigation Links CSS 

1. Insert text that will later become navigation links, click in the left cell of the 2nd row in the table. 

2. Change the vertical alignment to Top (See Figure 49). 

 

 
Figure 49 - Vertical Cell Alignment for Navigation Menu. 

3. Insert a Line Break. This spaces out the text from the top of the cell (See Figure 50). 

Note: The Line Break was obtained from the menu Insert > Character > Line Break. 

4. Type the text Navigation Menu and press Enter (See Figure 50). 

5. Insert a Horizontal Rule from the menu Insert > Horizontal Rule. 

6. Click below the Horizontal Rule, and type the text Home and press Enter (See Figure 50). 

7. Insert a Horizontal Rule from the menu Insert > Horizontal Rule. 

8. Repeat steps 6 and 7 for Biography and Resume (See Figure 50). 

Note: In our example, we will eventually create 3 web pages from this template. As such, there 

will be three links to point to the 3 different pages (Home, Biography, and Resume). 

 

 
Figure 50 - Setting up the Navigation Links Menu. 
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9. Create a new CSS selector to format the navigation links menu. Click on <style> for Source in 

the CSS Designer panel (See Figure 51). 

 

 
Figure 51 - Click on <style> to Create a Site Navigation Links Style. 

10. Click on the + sign to add a Selector in the CSS Designer panel (See Figure 52). 

11. Enter a name for the selector. In our example, the name is .Site_Navigation_Links (See Figure 

52). 

 

 
Figure 52 - Add CSS Selector Site_Navigation_Links. 
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12. From the Properties in the CSS Designer panel, we are going to set the following (See Figure 53). 

a. Click on the Text button. 

b. Choose your color for your text. 

c. Click on font-family to select a font. 

d. Click on font-style to select a style. 

e. Click on font-weight to select a weight. 

f. Click on font-size and select a size. 

g. Specify your text-align to select your alignment. 

 

  
Figure 53 - CSS Formatting for Site_Navigation_Links. 

13. Highlight text Navigation Menu. 

14. On the Properties Panel, click on the Targeted Rule drop-down and select 

Site_Navigation_Links (See Figure 54). 

 

 
Figure 54 - Applying CSS Site_Navigation_Links.  
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15. Repeat steps 13 and 14 for Home, Biography, and Resume (See Figure 55). 

 

 
Figure 55 - Site Navigation Links. 

Site Body Text CSS 

1. Create a new CSS selector to format the body text. Click on <style> for Source in the CSS 

Designer panel (See Figure 56). 

Note: This CSS selector will be applied after you create a webpage from the template. 

 

 
Figure 56 - Click on <style> to Create a Site Body Text. 

2. Click on the + sign to add a Selector in the CSS Designer panel (See Figure 52). 

3. Enter a name for the selector. In our example, the name is .Site_Body_Text (See Figure 57). 

 

 
Figure 57 - Add CSS Selector Site_Body_Text. 
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4. From the Properties in the CSS Designer panel, we are going to set the following (See Figure 58). 

a. Click on the Text button. 

b. Choose your color for your text. 

c. Click on font-family to select a font. 

d. Click on font-style to select a style. 

e. Click on font-weight to select a weight. 

f. Click on font-size and select a size. 

 

 
Figure 58 - CSS Formatting for Site_Body_Text. 
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Editable Region 

1. Click in the center cell of the 2nd row in the table. 

2. In the Properties panel, change the vertical alignment to Top (See Figure 59). 

 

 
Figure 59 - Vertical Cell Alignment for Editable Region. 

3. Insert an Editable Region in the cell by going to the menu Insert > Template > Editable Region. 

4. You can name your editable region whatever you want and click OK. In our example, the 

regio ’s a e is Edit Here  (See Figure 60). 

Note: Editable template regions control which areas of the template you can edit on the 

individual web pages based on the template. 

 

 
Figure 60 - Editable Region. 
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Save the Template Page 

1. Click on File, and then on Save as a Template…. 

Note: If you know that you will have multiple templates, you should give it a name that will 

indicate what the template is used for. 

2. Give it a name in the Save as field and click the Save button (See Figure 61). 

 

 
Figure 61 - Save as a Template. 

Leave the template open; we will work on it more as we go. After we create web pages from this 

template, we will come back and create links from the template to each page. 

 

Creating a New Web Page From a Template 

Once you have created a template, you can create one or more web pages from that template. In our 

example, we will create three web pages from the template that we just created. 

 

Note: Remember, any elements that are unique to one web page should be added to the web page 

that is created from the desired template.  
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1. Go to the menu File. 

2. Click on New. 

3. Select Site Templates from the New Document window (See Figure 62). 

4. Select the Site on which you are working (See Figure 62). 

5. Select the Template from which you wish to create a page (See Figure 62). 

6. Check the Update page when template changes (See Figure 62). 

7. Click the Create button (See Figure 62). 

 

 
Figure 62 - New Page from Template.  
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8. Click in the Editable Region on the page and enter content: text, tables, and images. Any 

content that you add to this page will be unique to this page. 

Note: When entering text, pressing the Enter key skips a line to start a new paragraph. If you do 

not want to skip a line, press Shift + Enter. 

9. Highlight the body text entered in the Editable Region. 

10. On the Properties Panel, click on the Targeted Rule dropdown and select Site_Body_Text (See 

Figure 63) 

Note: Use the CCS style .Site_Body_Text you created before. 

 

 
Figure 63 - Applying CSS Site_Body_Text. 

11. Save the page by going to the menu File > Save As. 

12. The first page (Home) must be saved as index.html. All other pages should have a meaningful 

name that is short, yet descriptive of the page (e.g. biography.html). 

Note: The filename is different from the title. The title determines what appears in the status 

ar of a isitor’s e  ro ser, hile the file a e is the a tual a e of the file o  the 
computer. 

13. Repeat the steps 1 through 12 to create additional web pages (See Figure 64). In our example, 

two additional pages are created: biography.html and resume html. 

 

 
Figure 64 - Text in Editable Region. 

  



  Page 40 of 54 

Adding Images to a Web Page 

Before you can add an image to a web page or template, you will need to have the image file on your 

local computer, preferably in a subfolder of your local web folder.  

 

Dreamweaver accepts the following image formats: .gif, .jpg, .png, and .psd. 

 

Inserting an Image 

1. Create a subfolder in your local web folder called Images, and then copy the image file into this 

subfolder. 

2. Open the web page in which you wish to insert an image. 

3. Click where you want to insert the image. The image will appear at your insertion point. 

4. Go to the menu Insert > Image > Image. 

5. Navigate to the Images subfolder in your local web folder from the Select Image Source window 

(See Figure 65). 

6. Select the image file and click OK. 

 

 
Figure 65 - Select Image Source.  
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Image Tag Accessibility Attributes 

When used, the alternate text attribute displays a tooltip in Internet Explorer with the words you 

entered for the website visitors when they place their cursor over the image. Not only is this helpful to 

your website visitors who use Internet Explorer, it is helpful for the visitors who have images turned off 

and it makes your site accessible.  

 

1. Enter a keyword to describe the image in the Alternate Text field (See Figure 66). 

Note: The keyword will be displayed where the image would normally appear for those with 

images turned off and is read out loud to those who use assistive technology to read web 

pages. It is also displayed in a tooltip when the mouse cursor is placed over the image in 

Internet Explorer. 

Note: Selecting the image displays all of the properties for that image in the properties panel 

(See Figure 66). 

 

 
Figure 66 - Image Properties. 

Resize the Image 

You may need to resize the image once it is placed on the page. 

1. Select the image by clicking on it. 

2. Press and hold the Shift key while dragging the image from the bottom right corner, and then 

release (See Figure 67). 

 

 
Figure 67 - Resizing the Image.  



  Page 42 of 54 

Adding Hyperlinks to a Web Page 

A hyperlink is underlined text that, when clicked, will request that another web page be loaded and 

displayed in the browser window. A hyperlink starts as simple text and is then converted to a link using 

the properties panel.  

 

There are two basic types of hyperlinks: 

 Internal - An internal hyperlink is a link that points to a web page from the same website. 

 External - An external hyperlink is a link that points to a web page from another website. 

 

Following our original design, we want to make the text (Home, Biography, and Resume), point to the 

other pages in our website. 

 

Creating Internal Hyperlinks 

We are going to create internal navigation links for our project. 

1. Edit the template page. 

2. Highlight the text Home on your navigation menu with your mouse cursor. 

3. Select HTML button on the properties panel (See Figure 68). The HTML properties appear. 

4. In the Properties panel, click on the Browse for File (Folder) icon that is next to the Link field 

(See Figure 68). The Select File window opens. 

 

 
Figure 68 - Hyperlink, Browse for File. 
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5. Select the index.html file (See Figure 69). 

6. Click OK (See Figure 69). 

7. Repeat the steps 2-6 for the biography and resume navigation menu links. 

 

 
Figure 69 - Select File. 

Creating External Hyperlinks 

1. Enter My Favorite News Site below Resume in the navigation menu of the template. 

2. Highlight the new text in the Navigation menu. 

3. Set the Class to Site_Navigation_Links (See Figure 70). 

4. Enter the full web address into the Link box on the Properties panel (See Figure 70). 

Note: If you want the link to open the web page in a new browser tab or window, you can 

choose _blank from the Target box. 

 

 
Figure 70 - External Hyperlink.  
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Save the Hyperlinks 

1. Save the changes to the template by clicking on File > Save. 

2. A prompt to update all files based on this template appears. Click Update to transfer the 

changes to all of the files that were created from this template (See Figure 71).  

 

 
Figure 71 - Update Files with Template Changes. 

3. When the Update Pages window appears click Close (See Figure 72). 

 

 
Figure 72 - Update Pages. 

4. An asterisk appears in each of the web pages tab to indicate that they need to be saved to 

confirm the change (See Figure 73). 

 

 
Figure 73 - Asterisk to Notify Web Pages to Update. 
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5. Right-click on the tab of one of the web pages with an asterisk, and then select Save All from 

the menu (See Figure 74). 

 

 
Figure 74 - Save All Web Pages. 

Adding Anchor Links to a Web Page 

Named anchors are a link to a specific section of a page. Anchor links are frequently used for table of 

contents and for frequently asked questions. In our example, we will add a Return to Top of Page link 

to make it convenient to go back all the way up with a single-click. 

 

1. Insert the cursor in a location on the page that you want to link to (See Figure 75). The anchor 

may be placed before a line of text or on its own line. 

 

 
Figure 75 - Cursor Placed Before Text. 

2. Type TopOfPage into the ID box on the Properties panel (See Figure 76). 

 

 
Figure 76 - Named Anchor. 
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3. Type the text Return to Top of Page (See Figure 77). 

4. Highlight the text. 

 

 
Figure 77 - Return to Top of Page Text. 

5. Type #TopOfPage into the Link box on the Properties panel (See Figure 78). 

 

 
Figure 78 - Anchor Hyperlink to Top of Page. 

Publishing Your Website 

You can now upload your files from your local folder to the remote server to make your pages publicly 

accessible on the web. 

 

Note: You must define your site as detailed in the Defining a Site section before you can publish. 
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1. Select the topmost folder of your site in the Files panel (See Figure 79). 

 

 
Figure 79 - Topmost Folder in Files Panel. 

2. Click the Put button on the Files panel (See Figure 80). 

 

 
Figure 80 - Put Files to Remote Server. 

3. The Are you sure you wish to put the entire site?  window appears, Click OK (See Figure 81). 

Note: If you have any unsaved files, Dreamweaver will prompt you to save. Choose Yes to save 

your work. 

 

 
Figure 81 - Put Confirmation.  
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4. If asked  Should dependent files be included in the transfer?, select Yes. This insures that any 

external files such as images that are referred to in your pages, are included. 

5. After these steps are completed, your site is now uploaded to your web space. 

Note: Because of the way that web publishing is done, you end up with copies of your web 

pages in two locations: on your local machine, and on the web server which hosts your website.  

 

Compare the Content 

You can compare the content of both locations in a side-by-side view to ensure that all files 

transferred. 

1. Click the Expand/Collapse button in the Files panel (See Figure 82). 

 

 
Figure 82 - Expand/Collapse Button. 

2. The side-by-side Remote Server and Local Files views window appears (See Figure 83). 

 

 
Figure 83 - Remote and Local Views. 

Note: If there is any difference between the two sites, it could be because you have made 

changes to your local files but have not used the Put command to upload them yet. 
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3. To collapse the side-by-side views window, click on the Expand/Collapse button on the top bar 

(See Figure 84).  

 

 
Figure 84 - Collapse Local/Remote Site Window. 

Viewing Your Website 

Anyone anywhere can now view your website if they have an Internet connection, a web browser, and 

know your web address. Your web address will be one of the following: 

 For Students: http://studentweb.kennesaw.edu/~yournetID 

 For Faculty/Staff: http://ksuweb.kennesaw.edu/~yournetID 

Note: our etID  is our user a e for loggi g i to K“U o puters. 
 

Reconnecting From Another Location 

When you want to make changes to your website from another location which does not have your 

local folder, you first have to connect Dreamweaver to your existing site and then download the files 

so you can edit them. 

1. Create a folder on the local computer, and follow the instructions for Defining a Site to create 

the site definition. 

2. From the Files panel, click the Get File(s) button to download a copy of your website on your 

local computer (See Figure 85).   

 

 
Figure 85 - Get Files from Remote Server. 

3. Once you have done this, you can make changes and additions to your website. To open up a 

web page for editing, double-click on the file from the Files panel.  

http://studentweb.kennesaw.edu/~yournetID
http://ksuweb.kennesaw.edu/~yournetID
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Backing Up Your Site Definition 

You may use the export/import functions of the site definition tool to back up your site definition 

and/or transfer it to a different computer. 

 

To Back Up The Site Definition 

1. Select Site from the Menu bar. 

2. Click on Manage Sites…. 

3. Select your site definition, and then click the Export button from the Manage Sites window (See 

Figure 86). 

 

 
Figure 86 - Manage Sites Export. 

4. Make the appropriate selection, and then click OK from the Exporting site window (See Figure 

87). 

 

 
Figure 87 - Exporting Site.  
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5. Browse to the location where you wish to save the site definition, and then click Save from the 

Export Site window (See Figure 88). 

 

 
Figure 88 - Export Site Window. 

6. Click Done to close the Manage sites window. 
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To Restore The Site Definition 

1. Select Site from the Menu bar. 

2. Click on Manage Sites…. 

3. Click the Import button from the Manage Sites window (See Figure 89). 

 

 
Figure 89 - Manage Sites Import. 
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4. Browse to the location of the site definition, select it, and then click Open from the Import Site 

window (See Figure 90). 

 

 
Figure 90 - Import Site Window. 

5. Click Done to close the Manage sites window. 
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Resources 

OwlTrain has many Dreamweaver resources available to you on their website: 

 OwlTrain: http://owltrain.kennesaw.edu/ 

 

Additional Help 

For additional help or installation issues, please contact the KSU Service Desk (Faculty & Staff) or the 

KSU Student Help Desk (Students). 

 

KSU Service Desk for Faculty & Staff 

 Phone:  470-578-6999 

 Email:   service@kennesaw.edu 

 Website:  http://uits.kennesaw.edu/faculty-staff/ 

KSU Student Help Desk 

 Phone:  470-578-3555 

 Email:   studenthelpdesk@kennesaw.edu 

 Website:  http://uits.kennesaw.edu/students/ 

http://owltrain.kennesaw.edu/
mailto:service@kennesaw.edu
http://uits.kennesaw.edu/faculty-staff/
mailto:studenthelpdesk@kennesaw.edu
http://uits.kennesaw.edu/students/
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