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This booklet is the companion document to the Excel 2016: Advanced Excel Tools workshop. The 

booklet will explain how to create a simple macro, how to use nested formulas, how to create 

templates, hide/unhide rows and columns, and protect/unprotect your spreadsheets and workbook. 

 

Learning Objectives 

After completing the instructions in this booklet, you will be able to: 

 Understand what Nested Functions are. 

 Link data between sheets. 

 Understand what Macros are. 

 Create a simple Macro. 

 Hide/unhide information in your spreadsheet. 

 Protect your spreadsheet and workbook. 

 Create templates out of workbooks. 
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Creating Nested Functions 

Nested functions are functions within a function. By nesting an IF function within an existing IF 

function, you can test more than one conditions (e.g. Pass, Conditional, Fail). This can be helpful if you 

want to assign scores or grades based on certain conditions. 

 

For example: =IF(F2>=75,"Pass",IF(F2>=65,"Conditional","Fail")) 

 

This formula checks the cell for a value, and if it is greater than or equal to (>=) a predetermined grade 

(e.g. 75), then the formula will return the phrase Pass. If the number in the cell is less than 75, Excel 

will move to the next part of the formula, and so on.  

 

 
Figure 1 - Nestled IF Function 

Note: Pass is in quotes to indicate to Excel that this is the value we want returned, and it is not another 

function. 

 

Linking Data  

Linking data between spreadsheets allows you to reference data contained elsewhere in your 

workbook without having to copy all of the information. For example, you could have a workbook that 

has multiple spreadsheets tracking regional sales and a separate spreadsheet to tally the totals across 

all regions. By linking to the regional data from the totals, you will only have to update your 

information in one location. The following example explains how to link data between the Eastern 

Division spreadsheet, and the Year End Total spreadsheet:  

 

1. Open the spreadsheet that contains the source data and the target location (e.g. Eastern 

Division, Western Division, Totals, etc) 

2. Select the cell(s) in the source spreadsheet that contain the data that you want to link to the 

target location (e.g. Total sales for Eastern Division).

 

 
Figure 2 - Selected Cells 
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3. Right-click on the selected cells. 

4. A context sensitive menu will appear. Click Copy. 

 

 
Figure 3 - Copy 

5. Go to the target location (e.g. year-end totals sheet) and select the cell(s) where you want to 

link the source data. 

 

 
Figure 4 - Paste Location 

6. Right-click on the selected cells.  

7. A context sensitive menu will appear. Click on the Paste Link icon. 

 

 
Figure 5 - Paste Link 

8. The selected cells on the Year End spreadsheet are now linked with the cells on the Eastern 

Division spreadsheet. The data will now be updated whenever the source data is changed. 
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Macros 

Macros are programs that run within Excel that can help to automate common repetitive tasks, thus 

saving time and boosting productivity with a simple click or command. For example, if you wanted to 

delete a row within your spreadsheet, you would need to select the row, click the Home tab, select 

delete, and then click delete rows. Instead, you can create a macro that completes the entire sequence 

with a single click or keystroke. 

 

Enabling the Developer tab 

Before you can record a macro, you will need access to the Developer tab in the Ribbon. The following 

steps explain how to add the Developer tab to the Ribbon: 

 

1. Right-click in an empty section within the Ribbon. 

2. A dialog box will appear. Select Customize the Ribbon. 

 

 
Figure 6 - Customize the Ribbon 

3. The Customize Ribbon window will appear, with options to customize the ribbon on the right. 

 

 
Figure 7 - Customize the Ribbon Options 
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4. Click the checkbox next to Developer. 

 

 
Figure 8 - Developer Checkbox 

5. Click OK. 

6. The Developer Tab will now be displayed in the Ribbon. 

 

 
Figure 9 - Developer Tab 

 

Recording a Macro 

When recording your macro, Excel will register every mouse-click and keystroke as part of your macro 

until you stop recording. It is important to have the steps you wish Excel to record thought out 

beforehand. The following example describes how to create a simple macro that will delete an entire 

row:  

 

Note: If the Developer tab is not available, see the section on Enabling the Developer tab. 

 

1. In the Ribbon, click on the Developer tab. 

 

 
Figure 10 - Developer Tab 
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2. In the Code group, click on Use Relative References. 

 

 
Figure 11 - Use Relative References 

Note: With Use Relative References enabled, macros are recorded with actions relative to the initial 

selected cell. 

 

3. In the Code group, click Record Macro. 

 

 
Figure 12 - Record Macro  

4. The Record Macro window appears. In the Macro Name field, type a name.Make sure the name 

has no spaces, and starts with a letter or underscore (See Figure 13). 

5. In the Shortcut key field, enter a shortcut key. This will be the keyboard command you use to 

activate your Macro (See Figure 13).  

6. In the Store macro in: field, click the down arrow, and select where you want the macro to be 

stored. If you plan to use a macro with more than one workbook, select the Personal Macro 

Workbook option (See Figure 13). 

7. Enter a description of the macro in the Description field (See Figure 13). 

8. You are ready to record the steps of the macro. Click OK to begin recording (See Figure 13). 

 

 
Figure 13 - Record Macro Window   

Note: When recording your macro, Excel will register every mouse-click and keystroke as part of your 

macro until you stop recording. 
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9. In your spreadsheet, select a row you wish to delete. 

10. In the Ribbon, click on the Home tab. 

 

 
Figure 14 - Home Tab 

11. Under the Cells grouping, click on the arrow below Delete.  

 

 
Figure 15 – Delete 

12. From the drop-down, click Delete Sheet Rows. 

 

 
Figure 16 - Delete Sheet Rows 

13. The selected row will be deleted. 

14. Click on the Developer tab. 

 

 
Figure 17 - Developer Tab 
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15. In the Code grouping, click Stop Recording. 

 

 
Figure 18 - Stop Recording  

16. If done correctly, your macro will have been captured. To run your DeleteRows macro, select 

the row to delete and press CTRL+r. 

 

Note: If your macro is not running as intended. It is easier to delete the macro and record again. See 

the Managing your Macros section for more information. 

 

Managing your Macros 

Once you have created a macro, you can run it without using the keyboard shortcut, delete it, edit it, 

or change the keyboard options for it. 

 

1. In the Ribbon, click the Developer tab. 

 

 
Figure 19 - Developer Tab 

2. In the Code group, click Macros. 

 

 
Figure 20 – Macros 
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3. The Macro window will open. A list of your created macros will be displayed. 

a. To run a macro, select it from the list, and click Run (See Figure 21). 

b. To edit a macro in Visual Basic, select it from the list, and click on Edit (See Figure 21). 

c. To delete a macro, select it from the list, and click on Delete (See Figure 21).  

d. To change the shortcut key or description for the macro, select it from the list, and click on 

Optio s… (See Figure 21). 

e. Click Cancel when finished (See Figure 21).  

 

 
Figure 21 - Macro Window 

Note: You will need to understand Visual Basic in order to edit a macro. If you need to make a 

correction and are not familiar with Visual Basic, it would be easier to delete the macro and re-record. 

 

Moving Spreadsheets 

You can easily rearrange the spreadsheet tabs in your workbook to keep them in order. The following 

explains how to move spreadsheets: 

 

1. Left-click and hold the spreadsheet tab at the bottom of your spreadsheet. 

 

 
Figure 22 - Spreadsheet Tab 
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2. Drag the spreadsheet tab in-between any existing spreadsheet. Your cursor will change to show 

you are moving a spreadsheet.  

 

 
Figure 23 - Dragging Spreadsheet 

3. Release the left-mouse button to finish moving your spreadsheet.  

 

Note: You can also move a spreadsheet using the Move or Copy tool: 

 

1. Right-click on the spreadsheet tab you wish to move. 

2. A context sensitive menu will appear. Click Move or Copy. 

 

 
Figure 24 - Move or Copy... 

3. The Move or Copy window will appear. Under Before sheet, select where you want the currently 

selected spreadsheet to be moved. 

 

 
Figure 25 - Move or Copy Window 

4. Click OK. The spreadsheet will be moved before the selected location. 
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Copying Spreadsheets 

Duplicating a spreadsheet can be done with the Move or Copy tool. The following explains how to copy 

spreadsheets: 

 

1. Right-click on the spreadsheet tab you wish to copy. 

2. A context sensitive menu will appear. Click on Move or Copy. 

 

 
Figure 26 - Move or Copy... 

3. The Move or Copy window will appear. Under Before sheet, select where you want the copy of 

the currently selected spreadsheet to be moved (See Figure 27). 

4. Next to Create a Copy, click the checkbox (See Figure 27). 

5. Click OK. A copy of the spreadsheet will be made before the selected location (See Figure 27). 

 

 
Figure 27 - Move or Copy Window 
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Hiding Rows and Columns 

Hiding rows and/or columns in your spreadsheet will hide them from view so you can focus on other 

parts of your table. To hide a row or column: 

 

1. Select the row/column in your spreadsheet. 

 

 
Figure 28 - Selected Column 

2. Right-click on the selected row/column. 

3. A context sensitive menu will appear. Click Hide. 

 

 
Figure 29 - Hide 

4. The selected row/column will be hidden. 

 

 
Figure 30 - Selected Column Hidden 

 

Hiding Spreadsheets 

You can also hide whole spreadsheets if needed. To hide a spreadsheet: 

 

1. Right-click on the spreadsheet tab.  

2.  A context sensitive menu will appear. Click on Hide.  

 

 
Figure 31 - Hide Spreadsheet 

3. The selected spreadsheet will be hidden.  



  Page 16 of 26 

 

Unhiding Rows and Columns 

To identify hidden rows/columns in your spreadsheet, pay attention to the numbering (rows) or 

lettering (columns). If they appear to skip within their sequence, then rows/columns are hidden. To 

unhide rows and columns: 

 

1. Select the rows/columns surrounding the hidden rows/columns. 

 

 
Figure 32 - Select Hidden Rows/Columns 

2. Right-click on the selected row/column. 

3. A context sensitive menu will appear. Click Unhide. 

 

 
Figure 33 – Unhide 

4. The hidden rows/columns will now be visible. 

 

 
Figure 34 - Unhidden Column 
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Unhide Spreadsheets 

The following shows how to unhide spreadsheets: 

 

1. Right-click on a spreadsheet tab. 

2. A context sensitive menu will appear. If Unhide is not greyed out, there are hidden spreadsheets 

within your workbook. Click on Unhide. 

 

 
Figure 35 - Unhide Spreadsheet 

3. The Unhide window will appear. Select a spreadsheet to unhide from the list. 

 

 
Figure 36 - Unhide Window 

4. Click OK.  

5. The spreadsheet will now be visible.  

 

Protecting your Spreadsheets 

Protecting your spreadsheet can limit what cells other users can select, and even what types of edits 

are allowed. This feature is helpful if you have created a spreadsheet with complex formulas that you 

do not want to be deleted, or if you just want to limit where users can enter information (e.g. an 

inventory spreadsheet which asks users to fill in specific sections). You can choose to 

protect/unprotect specific cells in your spreadsheet, or lock an entire spreadsheet. 

 

By default, Excel assumes that you will want to lock all cells in your spreadsheet. If you wish users to be 

able to edit specific cells, you will first need to prepare the cells so they can be edited by unlocking 

them while the rest of the cells in your spreadsheet remain locked. 
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Preparing your Cells  

Before locking your spreadsheet, you will need to unlock the cells that you want users to be able to 

edit. For example, you have a quarterly sales spreadsheet with formulas in the totals column. You want 

users to enter values for their quarter, but let Excel calculate the totals. You can unlock the quarter 

columns so it is the only part of the spreadsheet users will be able to access. 

 

The following explains how to unlock cells within your spreadsheet: 

 

1. Select the cells that you want to enable users to edit. 

 

 
Figure 37 - Selected Cells to Unlock 

2. Right-click the selected cells. 

3. A context sensitive menu will appear. Click For at Cells…. 

 

 
Figure 38 - Format Cells... 

4. The Format Cells window will appear. Click the Protection tab. 

 

 
Figure 39 - Protection Tab 
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5. Uncheck the checkbox next to Locked. This will allow users to make changes to the selected 

cells. 

 

 
Figure 40 - Unlock Selected Cells 

6. Click OK. 

7. The selected cells are now set to unlocked. You will need to lock your spreadsheet to enable 

protection (See Locking your Spreadsheet for more information). 

 

Locking your Spreadsheet 

Once you have designated which cells are to remain unlocked (See Preparing your Cells), you can 

protect the spreadsheet to lock the rest of your cells (e.g. cells that contain necessary formulas or 

instructions for users). 

1. In the Ribbon, click the Review tab. 

 

 
Figure 41 - Review Tab 

2. In the Changes grouping, click Protect Sheet. 

 

 
Figure 42 - Protect Sheet 
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3. The Protect Sheet window will appear. Click the checkbox next to Protect worksheet and 

contents of locked cell (See Figure 43). 

4. Enter a password if desired. You will be asked to confirm your password if you create one  

(See Figure 43). 

5. Next to Select locked cells, uncheck the checkbox (See Figure 43). 

6. Make sure the checkbox next to Select unlocked cells is checked. This will enable users to access 

and make changes to unlocked cells (See Figure 43). 

7. Click OK (See Figure 43)  

 

 
Figure 43 - Protect Sheet Window 

 

Note: Without a password, anyone can easily unprotect the sheet. If you forget your password, it 

cannot be retrieved, so make sure to write it down and keep it in a safe place. 

 

8. Your spreadsheet will be protected. Only the unlocked cells will be selectable. 

 

Unprotect Worksheets 

The following explains how to unprotect a worksheet that has been locked for editing: 

 

1. In the Ribbon, click the File tab. 

 

 
Figure 44 - File Tab 
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2. The Backstage View will appear, and the protect workbook information will display any 

spreadsheets that are currently locked. 

 

3. Click Unprotect next to the spreadsheet you want to unprotect. 

 

 
Figure 45 - Unprotect Spreadsheet 

4. If the spreadsheet is password protected, you will be prompted to enter the password. Once 

entered, click OK. 

5. The selected spreadsheet has been unlocked and is ready to be edited.  

 

Protecting Workbooks  

You can protect an entire workbook to prevent unwanted changes such as moving, deleting, or adding 

sheets. To protect a workbook: 

 

1. In the Ribbon, click the Review tab. 

 

 
Figure 46 - Review Tab 

2. In the Changes grouping, click on Protect Workbook. 

 

 
Figure 47 - Protect Workbook 
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3. The Protect Structure and Windows window will appear. Make sure that the checkbox next to 

Structure is checked (See Figure 48). 

4. Enter a password if desired. You will be asked to confirm your password if you create one  

(See Figure 48). 

5. Click OK. Your workbook will be protected (See Figure 48). 

 

 
Figure 48 - Protect Structure and Windows 

Note: Without a password, anyone can easily unprotect the workbook. If you forget your password, it 

cannot be retrieved, so make sure to write it down and keep it in a safe place. 

 

Unprotect Workbooks 

The following explains how to unprotect a protected workbook: 

 

1. In the Ribbon, click the Review tab. 

 

 
Figure 49 - Review Tab 

2. In the Changes grouping, click Protect Workbook. 

 

 
Figure 50 - Unprotecting Workbook 

Note: If the workbook is currently protected, the protect workbook icon will be shaded grey.  

 

3. If the spreadsheet is password protected, you will be prompted to enter the password, then 

click OK.  

4. The protection on the workbook has been removed. 
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Creating Templates 

Templates help you to create documents with special formatting for your desired task (e.g. calendar 

template, inventory template, schedule template, etc). You can create your own templates based off of 

an existing spreadsheet. 

 

The sample below shows a template for calculating first quarter sales for a company. This template 

was created by modifying an existing spreadsheet and saving it as a template file. The template could 

also have been created from a new spreadsheet, with the formulas for totals saved in the proper cells. 

 

 
Figure 51 - Template Example 

To prepare your spreadsheet as a template: 

 

1. Create your spreadsheet as normal (e.g. formatting, headers, formulas for totals, etc.) 

2. In the Ribbon, click the File tab. 

 

 
Figure 52 - File Tab 

3. The Backstage View will appear. Click Save As. 

 

 
Figure 53 - Save As 
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4. The Save As options will display. Click Browse. 

 

 
Figure 54 - Click Browse 

5. The Save As window will open. In the File name: field, enter a name for the template  

(See Figure 55).  

6. In the Save as type field, select Excel Macro-Enabled Template (See Figure 55). 

7. Click Save (See Figure 55). 

 

 
Figure 55 - Excel Macro-Enabled Template 

8. Your template will be saved in the My Documents/Custom Office Templates folder. 
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Using a Template 

The following explains how to access the custom-made template created in the Creating Templates 

section. 

 

Note: The following instructions show how to access templates saved to the default My 

Documents/Custom Office Templates location on your computer. 

 

1. In the Ribbon, click on the File tab. 

 

 
Figure 56- File Tab 

2. The Backstage View will appear. Click New. 

 

 
Figure 57 - New 

3. The New options will display. Click Personal to access your custom templates. 

 

 
Figure 58 - Custom Templates 
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4. Your created templates will be displayed. Click on your desired template.  

 

 
Figure 59 – Created Templates 

 

Additional Help 

For additional support, please contact the KSU Service Desk: 

 

KSU Service Desk for Faculty & Staff 

 Phone:  470-578-6999 

 Email:   service@kennesaw.edu 

 Website:  http://uits.kennesaw.edu 

KSU Student Helpdesk 

 Phone:  470-578-3555 

 Email:   studenthelpdesk@kennesaw.edu 

 Website:  http://uits.kennesaw.edu 

mailto:service@kennesaw.edu
http://uits.kennesaw.edu/
mailto:studenthelpdesk@kennesaw.edu
http://uits.kennesaw.edu/

	Introduction
	Learning Objectives
	Creating Nested Functions
	Linking Data
	Macros
	Enabling the Developer tab
	Recording a Macro
	Managing your Macros


	Moving Spreadsheets
	Copying Spreadsheets

	Hiding Rows and Columns
	Hiding Spreadsheets

	Unhiding Rows and Columns
	Unhide Spreadsheets

	Protecting your Spreadsheets
	Preparing your Cells
	Locking your Spreadsheet
	Unprotect Worksheets

	Protecting Workbooks
	Unprotect Workbooks


	Creating Templates
	Using a Template

	Additional Help

