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Organizing Worksheet
Data with Tables
Lesson Time: 1 hour, 15 minutes

Lesson Objectives
In this lesson, you will:

• Create and modify tables.

• Sort or filter worksheet and table data.

• Use functions to calculate data.

Lesson Introduction
You've built worksheets and workbooks and used functions and formulas to analyze data.
As your worksheets and workbooks grow in size and complexity, you might find it more
and more challenging to locate and study the data you need to make business decisions. You
want to organize the data in your Microsoft Office Excel 2013 files so that you can find the
data you need as efficiently as possible.
In this lesson, you will organize worksheet data with tables.
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TOPIC A
Create and Modify Tables
Imagine you have a worksheet with thousands of rows and a dozen columns. The worksheet lists
retail store transactions by date and various other criteria. You want to view all of the transactions
on a specific date between two specific hours. You could use Excel's sort functionality, but the
spreadsheet is so large, simple sorting would just take too much time. Additionally, because of the
sheer volume of transactions, with sorting, you might miss some of the transactions.
An easier way to find and summarize the data you're looking for is to convert your dataset into a
table. Tables enable you to quickly sort and filter data based on the header rows of the table. One of
the key benefits of tables is that a table limits the visible view of data to only the sort and filter
criteria you have selected. Tables don't manipulate or change the data; they manipulate and change
the view of the data.
So, if your transactions dataset is 175,000 rows long, and you want to see only the transactions that
occurred on August 20, 2012, between the hours of 10:00 a.m. and 11:00 a.m., for a specific store,
you can select these criteria from the date and time columns and the table will adjust its view so that
you see only the 137 transactions that occurred on that date between those hours for that store.
By removing all of the data you don't need to see from your view, Excel helps improve your
efficiency at finding and analyzing the data you do need.

Tables
A table is a dataset composed of contiguous rows and columns that Excel treats as a single,
independent data object. When a standard dataset is converted to a table, the header row converts
from plain text labels into sortable fields.

Table Components
Tables contain a variety of components that enhance the presentation of data.

Component Description

Table name Functions much the same way as a range name. You can add a name to a table
so that you can use the table name in formulas.

Header row The first row of a table that contains the labels for each column. Unlike
standard data ranges, table header rows include drop-down lists that enable
you to filter and sort the data in the table.

Total row The total row is the last row in a table. It can display the total or other
summary data for each column in the table.

Banded rows and
columns

Tables can be formatted so that rows and columns appear in different colors,
making it easier for users of the data to differentiate between one row or
column and another.
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Figure 1-1: A sample table.

The Create Table Dialog Box
You can use the Create Table dialog box to select a specific data range and convert it to a table.
You can find the Create Table dialog box by selecting INSERT→Tables→Table.

Figure 1-2: The Create Table dialog box.

Styles and Quick Style Sets
A style is a collection of formatting options that you can define and then apply to worksheet columns
and rows. A Quick Style Set is a group of predefined styles that come packaged with Excel. Quick
Style sets enable you to apply a predefined style quickly and easily to tables of any size.

The TABLE TOOLS DESIGN Contextual Tab
The TABLE TOOLS DESIGN contextual tab displays only when you have selected a table or a
cell within a table.
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Figure 1-3: The TABLE TOOLS DESIGN contextual tab.

Table Formatting Options
You can format a table by using any of the predefined Quick Style sets, or you can create your own
custom styles. Custom styles enable you to align the formatting of your table with any color and
formatting style guidelines that might be governed by other departments in your organization. For
example, if your firm has strict color branding guidelines for internal and external communications
and reports, you can use custom styles to align the formatting of your worksheets to meet those
branding guidelines.

Table Modification Options
Once you've built a table, you can modify it in various ways. You can add and delete columns and
rows while maintaining both the data and formatting integrity of the table. You change the size of
the table without impacting data that might appear elsewhere on the worksheet but not in the table.
If necessary, you can also convert a table into a data range if you need to remove the table
functionality from how the data is presented and viewed.

How to Create and Modify Tables
Use these procedures to a create a table and apply a style to it.

Note: Access the Checklist tile in the LogicalCHOICE Course screen to view all How To
procedures for this lesson.

Create a Table with the Default Table Style
To create a table with the default table style:
1. Before converting a range to a table, ensure you know the precise range that you wish to convert

to a table. You don't want to include any unnecessary rows or columns.
2. Select the range that you wish to convert to a table.
3. Select INSERT→Tables→Table.
4. In the Create Table dialog box, verify that Excel displays the correct range to convert to a table.

If necessary, edit the range.
5. If you want the cells in the top row of the selected range to become table headers, check the My

table has headers check box. If you want Excel to insert a row of default column headers,
uncheck the My table has headers check box.

6. Select OK.

Create a Table with a Quick Style Set
To create a table with a Quick Style set:
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1. Select the range that you want to convert to a table.
2. Select HOME→Styles→Format as Table, and then select your desired Quick Style set.
3. In the Format as Table dialog box, verify that the correct range is identified. If necessary, edit

the range.
4. If you want the cells in the top row of the selected range to become table headers, check the My

table has headers check box. If you want Excel to insert a row of default column headers,
uncheck the My table has headers check box.

5. Select OK.

Convert a Table to a Worksheet Data Range
To convert a table to a worksheet data range:
1. Select a cell within the table.
2. On the TABLE TOOLS DESIGN contextual tab, in the Tools group, select Convert to

Range.
3. In the Microsoft Excel dialog box, select Yes.
4. If necessary, remove the table style formatting from the range.

Insert Table Rows
To insert table rows:
1. Select a cell that is in the row that will appear immediately below the new row.
2. Right-click and select Insert→Table Rows Above. Note: When inserting or deleting rows or

columns, you can select more than one cell to insert or delete the same number of rows or
columns. For example, if you want to insert five rows above the current cell B5, you could select
the range B5:B9, right-click, and select Insert→Table Rows Above.

Delete Table Rows
To delete table rows:
1. Select a cell that is in the row that you want to delete.
2. Right-click and select Delete→Table Rows.

Insert Table Columns
To insert table columns:
1. Select a cell that is in the column that will appear immediately to the right of the new column.
2. Right-click and select Insert→Table Columns to the Left.

Delete Table Columns
To delete table columns:
1. Select a cell that is in the column that you want to delete.
2. Right-click and select Delete→Table Columns.

Resize a Table
To resize a table:
1. Select a cell within the table. Note: In this context, resizing a table does not resize the width of

columns or the height of rows. Rather, it resizes the range of data that is included in the table by
either increasing or decreasing the size of the range.

2. On the TABLE TOOLS DESIGN contextual tab, in the Properties group, select Resize
Table.

3. Select the new data range and then select OK.
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Remove Duplicate Rows in a Table
To remove duplicate rows:
1. Select the table. Note: It is strongly recommended that before you use the Remove Duplicates

dialog box to delete any data, you save a safe copy of your worksheet in a secure location. You
will always be able to roll back to the safe copy in the event that Excel removed rows you
actually wanted to keep. Until you are comfortable using this functionality, you might consider
first sorting your data, looking for duplicates, running Remove Duplicates, and then verifying
the data you expected to be removed was removed.

2. On the TABLE TOOLS DESIGN contextual tab, in the Tools group, select Remove
Duplicates.

3. In the Remove Duplicates dialog box, in the Columns area, select and deselect the columns in
which you are looking for duplicates.

4. Verify that only the columns that contain potential duplicates are selected.
5. Select OK.
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ACTIVITY 1-1
Converting a Range to a Table

Data Files
C:\091015Data\Organizing Worksheet Data with Tables\Author_Data_03.xlsx

Before You Begin
Excel 2013 is open.

Scenario
In the last year, Fuller & Ackerman (F&A) acquired two publishing houses, bringing the total
number of F&A authors to just over 1,000. The process of integrating the author rosters of the two
new acquisitions is well underway.
With the addition of all the new authors, the Author Data worksheet has grown considerably. You
still need to run various reports based on the data, but because the number of records has grown
significantly, you have decided to convert the Author_Totals worksheet dataset into a table named
Author_Totals.

1. Open the file Author_Data_03.xlsx.

2. Convert the range A1:K1074 to a table.
a) Select any cell within the range A1:K1074.
b) Select INSERT→Tables→Table.
c) Verify that Excel has correctly anticipated the range =$A$1:$K$1074, and then select OK.

 

 
d) Adjust the width of each column so the drop-down list arrows do not obscure any of the column

labels.
 

 

3. Because F&A s brand colors are in the green spectrum, change the default color style of the table to a
green style.
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a) Select any cell in the table.
b) Select TABLE TOOLS DESIGN→Table Styles→More button

 

 
, and then select the Table Style Medium 11 quick style.
 

 

4. Name the new table Author_Totals
a) On the TABLE TOOLS DESIGN tab, in the Properties group, select the contents of the Table Name

field, and then type Table_Author_Totals
b) Press Enter.

5. Save your work as My_Author_Data_03.xlsx
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TOPIC B
Sort and Filter Data
Creating tables is one thing. Leveraging their power for data analysis is quite another. Sometimes
you will want to view your data in a specific order or view some subset of your data. In this topic,
you will sort and filter data.

The Difference Between Sorting and Filtering
Neither sorting nor filtering changes your data; they change only the view of your data.
To sort data means to change the order of data in a row or column. To filter data means to remove
from view any data that does not meet certain criteria. You can sort on one or more columns and
rows, and you can combine sorting and filtering to provide precisely the view you need. Generally
speaking, when you combine sorting and filtering, you filter first, and then sort the filtered data.
Here are some examples.
This table is sorted by AuthorID only. The sort goes from lowest value to highest value.

Figure 1-4: Data sorted on a single column.

This table is sorted by three columns: first by number of books in print, then by sell price, then by
number of books sold. To see this, first look at the order of the Number of Books in Print
column, which is the fourth column in the figure: the 1s come first, then the 2s. Then, within the 1s,
observe the order of the Sell Price (the sixth) column. It goes from lowest to highest sell price. The
same is true for the Sell Price order for authors with 2 books in print. Now observe the order of the
Number of Books Sold (the fifth) column for authors with one book sold. What do you notice?
The Number of Books Sold column is sorted from highest to lowest for each Sell Price.
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Figure 1-5: Data sorted on multiple columns.

When you sort on multiple columns, it's important to remember that each column you sort on—
except the last—must have data that repeats. In this example, there’s more than one author with 1
book in print, and there’s more than one sell price with multiples of each sell price. However, the
Number of Books sold is unique for each author.
The next example illustrates a table that has been both filtered and sorted. First, the table was
filtered to show only those authors who have earned between $100K and $150K. Then, the list of
authors returned by that filter was sorted from authors with the fewest books sold to the most
books sold.

Figure 1-6: Filtered and sorted data.

Excel has many AutoFilters built in. The previous example shows the table being filtered for authors
who have earned between $100K and $150K. This is an example of the Between AutoFilter.
Sometimes, though, you will want to filter data based on much more complex criteria than the
AutoFilter options will allow for. In cases like this, you will want to use the Advanced Filter dialog
box.

Advanced Filtering
The Advanced Filter dialog box enables you to create complex data filters that filter data on a
variety of user-defined criteria. However, if your data is in a table, to use the Advanced Filter dialog
box, you must first turn off AutoFilter.
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Unlike AutoFilter options, where you enter the filter criteria in the AutoFilter dialog box or select
it in a menu, the advanced filtering options look for specific filter criteria that appear in a specific
range, known as the criteria range, on your worksheet. The criteria range must appear directly above
the range you want to filter.
When you create advanced filters, criteria that appear on the same row in the criteria range use an
AND operator and criteria that appear on different rows in the criteria range use the OR operator.
Here are some examples.
This filter looks for all authors who have been under contract for 10 or more years, have five or
fewer books in print, and have sold 600,000 or more units. Five authors meet these criteria.

Figure 1-7: Advanced filter with three criteria using only the AND operator.

This filter looks for all authors who have been under contract for 11 or more years, have five or
fewer books in print, and have sold more than 600,000 units OR any authors who have earned more
than $16 million. Six authors meet these criteria.

Figure 1-8: Advanced filter with four criteria using both the AND and the OR operators.
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Filter Operators
Filter operators help you narrow down your search for specific data. You can use any of the
following filter operators in almost any combination.

Operator What It Does

“=text” Returns an exact match for the text that appears between the quotation marks and
after the equal sign.

? Serves as a wildcard character for a single character in the same position as the
question mark.

* Serves as a wildcard character for multiple characters in the same position as the
asterisk.

= Finds values equal to the filter criterion.

< Finds values less than the filter criterion.

> Finds values greater than the filter criterion.

<= Finds values less than or equal to the filter criterion.

>= Finds values greater than or equal to the filter criterion.

<> Finds values not equal to the filter criterion.

How to Sort and Filter Data
Use these procedures to sort and filter data.

Sort Data in a Range
To sort data in a range:
1. Select a cell in the column or row you want to sort.
2. Select HOME→Editing→Sort & Filter→Custom Sort.
3. In the Sort dialog box, select Options.
4. To sort data by columns, select Sort top to bottom (this is the most common type of sort), or to

sort data by rows, select Sort left to right (this is rarely used).
5. Select OK.
6. In the Sort dialog box, select Add Level to add the number of sort levels (criteria) you need. The

default is one level.
7. For each column (or row) sort level, define what to Sort by, what to Sort on, and the Order in

which you want the sort to appear.
8. Select OK.

Sort Data in a Table
To sort data in a table:
1. In the header row, in the drop-down list of the column you want to sort, select Sort smallest to

largest, Sort largest to smallest, or Sort by color. Note: If the content of the column (or row)
is textual as opposed to numeric, your options will be Sort A to Z and Sort Z to A.

2. If necessary, to create a custom sort, in the header row, in the drop-down list of the column you
want to sort, select Sort by color, and then select Custom Sort. In the Sort dialog box,
configure the sort criteria, and then select OK.
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Sort Data Based on Font Color
To sort data based on font color:
1. Verify that the data in the field you want to sort has more than one font color associated with it.

If the field has only one color, you won't be able to sort by font color. For example, if the field
has values that appear in green font if they are less than 10 or yellow font if they are greater than
10, then you'll be able to sort by color. If all of the values in the field are one color—black, for
example—you will not be able to sort on font color.

2. In the header row, in the drop-down list of the column you want to sort, select Sort by Color,
and then, in the Sort by Font Color section, select the font color you want to sort on.

Sort Data Based on Cell Color
To sort data based on cell color:
1. Verify that the data in the field you want to sort has more than one cell color associated with it.

If the field has only one color, you won’t be able to sort by cell color. For example, if the field
has values that appear in green cells if they are less than 10 or yellow cells if they are greater than
10, then you'll be able to sort by color. If all of the cells in the field are one color—for example,
no background color, or all yellow—you will not be able to sort on cell color.

2. In the header row, in the drop-down list of the column you want to sort, select Sort by Color,
and then, in the Sort by Cell Color section, select the cell color you want to sort on.

Filter Data Based on Font Color
To filter data based on font color:
1. Verify that the data in the field you want to filter has more than one font color associated with it.

If the field has only one color, you won't be able to filter by font color. For example, if the field
has values that appear in green font if they are less than 10 or yellow font if they are greater than
10, then you'll be able to filter by color. If all of the values in the field are one color—black, for
example—you will not be able to filter on font color.

2. In the header row, in the drop-down list of the column you want to filter, select Filter by Color,
and then, in the Filter by Font Color section, select the font color you want to filter for.

Filter Data Based on Cell Color
To filter data based on cell color:
1. Verify that the cells in the field you want to filter have more than one cell color associated with

them. If the field has only one color, you won't be able to filter by cell color. For example, if the
field has values that appear in green cells if they are less than 10 or yellow cells if they are greater
than 10, then you'll be able to filter by color. If all of the values in the field are one color—for
example, no background color, or all yellow—you will not be able to filter on cell color.

2. In the header row, in the drop-down list of the column you want to filter, select Filter by Color,
and then, in the Filter by Cell Color section, select the cell color you want to sort on.

Filter Data in a Table by Using Excel's AutoFilters
To filter data in a table by using AutoFilters:
1. In the header row, in the drop-down list of the column you want to filter, check or uncheck the

filter options you would like to use. Note: Filter options will vary depending upon the type of
data in the column. For example, if the column contains dates, you will be presented with filter
options relevant to dates. If the column contains numerical values, you will be presented with
filter options for numbers.

2. If necessary, you can search for specific data by typing your filter criteria directly in the Search
box and selecting the Search button. Note: The Search functionality will return only exact
matches. You cannot use operators such as “>” or “<=” in the Search box.

3. Select OK.
4. If necessary, refine your filter by adding additional filters to additional columns.
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Filter Data in a Table or Range by Using Advanced Filters
To filter data in a table by using advanced filters:
1. Create the criteria range, inserting enough rows above the table or range so that:

• The criteria range contains a header row that matches the header row of the dataset.
• In addition to the criteria range header row, there are enough rows to accommodate the total

number of OR criteria you want to filter for. Note: Criteria on the same row use the AND
operator. Criteria on separate rows use the OR operator.

• There is one blank row between the criteria range and the header row of the dataset.
2. Copy the header row of the dataset to the first row of the criteria range.
3. Enter filter criteria in the criteria cells.
4. Select any cell in the dataset.
5. Select DATA→Sort & Filter→Advanced.
6. In the Advanced Filter dialog box, verify that the List range is the range for the dataset.
7. If necessary, select the Criteria range, making sure to include the header row of the criteria

range and only rows that contain criteria. Note: The criteria range cannot contain blank rows.
The blank row between the criteria range and the dataset header row indicates where the criteria
range ends and the dataset begins.

8. Select OK.

Remove Duplicate Records
To remove duplicate records:
1. Select a cell within the column or row that contains the duplicate values. Note: It's

recommended that until you are extremely comfortable with using the deduplication
functionality, you first save a backup copy of your production workbook in a safe location and
then work on a copy of the workbook. Verify that the correct records in the copy are being
removed prior to removing them from the production version of the workbook.

2. Select DATA→Data Tools→Remove Duplicates.
3. In the Remove Duplicates dialog box, select the columns you want to delete duplicate values

from.
4. Select OK.
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ACTIVITY 1-2
Sorting Data and Removing Duplicate Records

Before You Begin
My_Author_Data_03.xlsx is open.

Scenario
In preparation for creating some reports, you are reviewing and verifying author data.
You notice the following:
• When you sort the author data by highest to lowest income earned, you see that some of the

authors have a negative value for Years Under Contract.
• When you sort the author data by lowest to highest AuthorID, you notice that many of the

AuthorIDs repeat.
Neither of these conditions is good. After some collaborative research with the human resources
(HR) team, you have discovered that during the integration process, some of the data was corrupted.
After consultation with HR, you decide to first remove all of the author records for any authors who
have a negative value for Years Under Contract. Then, with those records removed, you decide to
deduplicate any records with the same AuthorID.
HR has indicated that the correct value to keep for each duplicate AuthorID is the older of the two
records.

1. In My_Author_Data_03.xlsx, sort the dataset from highest to lowest income earned.
a) In cell G1, select the drop-down list arrow, and then select Sort Largest to Smallest.
b) Verify that rows 5, 21, and 23 contain negative values in the Years Under Contract field.
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2. Delete all records that contain a negative value in the Years Under Contract field.
a) In cell C1, select the drop-down list arrow, and then select Sort Smallest to Largest.
b) To delete all of the author records with a negative Years Under Contract value, select the range

A2:K40.
c) Before deleting the records, verify that AuthorID 2831 on row 40 is the last author with a negative

value.
 

 
d) Right-click any cell in the selected range, and then select Delete→Table Rows.

 

16  |  Excel 2013: Data Tables and Charts

Lesson 1: Organizing Worksheet Data with Tables OTS Training

If necessary, let students
know there are more
authors with a negative
value in this field. They
are just using these
three because they are
the first three in this
particular sort.



 
e) With the dataset still sorted from lowest to highest Years Under Contract, verify that author 1989 is

now the first author in the list.
 

 

3. Sort the dataset by AuthorID and then by Initial Contract Date.
a) Select any cell within the table.
b) Select HOME→Editing→Sort & Filter→Custom Sort.

Note: When Excel deletes duplicate values, it deletes all of the records except
the first record of the duplicates. Because you want to retain the oldest of the
duplicate pairs, you want to first sort by AuthorID and then, within that sort, list
AuthorIDs by Initial Contract Date with the oldest contract date first.

c) In the Sort dialog box, in the Column area, from the Sort by list, select AuthorID.
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d) In the Sort On area, verify Values is selected.
e) In the Order area, verify Smallest to Largest is selected.
f) Select Add Level.
g) For the new level, set Column to Initial Contract Date, Sort On to Values, and Order to Oldest to

Newest.
 

 
h) Select OK.

4. Highlight and sort the duplicate values from oldest to newest.
a) Select the range A2:A1035.
b) On the HOME tab, in the Styles group, select Conditional Formatting→Highlight Cells

Rules→Duplicate Values.
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c) In the Duplicate Values dialog box, verify that Duplicate is selected and then, from the values with
drop-down list, select Yellow Fill with Dark Yellow Text.
 

 
d) Select OK.

5. How can you verify that the sort and highlight are working correctly?
A: Observe rows 18 to 21. Note that there are four instances of AuthorID 1034 and these are sorted

from oldest to newest.

6. If the deduplication works correctly, for the four AuthorIDs in question, which records would you expect
to remain in the dataset?
A: For AuthorID 1013, the duplicate records are for dates 10/16/2006 and 7/22/2003. Because HR

indicated that only the records with the oldest Initial Contract Date should remain, if deduplication
works correctly, then AuthorID 1013 should have one record left for date 7/22/2003. The correct
dates for the other three AuthorIDs appear in bold, as follows: AuthorID 1015: 8/16/2011 (delete)
and 5/3/2009 (remain); AuthorID 1034: 2/6/2012 (delete), 11/22/2007 (delete), 12/30/2005
(delete), and 1/17/2002 (remain); AuthorID 1364: 7/2/2007 (delete) and 9/13/2000 (remain).

7. Delete the duplicate records.
a) Select DATA→Data Tools→Remove Duplicates.
b) Because you want to delete only duplicates based on AuthorID, select Unselect All to clear all the

check boxes, and then check AuthorID.
 

 
c) Select OK.
d) In the dialog box that confirms 222 duplicate values were removed, select OK.

8. How can you verify that the correct records remain in the dataset?
A: For the four AuthorIDs noted above (1013, 1015, 1034, and 1364), only the following records

should remain in the dataset: for AuthorID 1013 the Initial Contract Date should be 7/22/2003, for
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If all of your students are
onsite, invite one student
up to the white board
and ask him or her to
write down the AuthorID
and the Initial Contract
Dates for each of the
following AuthorIDs:
1013, 1015, 1034, and
1364. If any of your
students are remote,
consider asking one of
the remote students to
write the data either on
the presentation
software's whiteboard
tool or in another
application and share
the desktop.



AuthorID 1015 the Initial Contract Date should be 5/3/2009, for AuthorID 1034 the Initial Contract
Date should be 1/17/2002, and for AuthorID 1364 the Initial Contract Date should be 9/13/2000.

9. Verify that there are no more duplicate AuthorIDs by using one of the following methods:
a) Select the range of AuthorIDs and use conditional formatting to highlight duplicates.
b) Select the range of AuthorIDs and then, on the DATA tab, in the Data Tools group, verify whether

the Remove Duplicates button is active. If a range is selected and the Remove Duplicates button is
active, then the range contains duplicates. If the button is inactive, then the range does not contain
duplicates.

10. Save your work.
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Before continuing, verify
that all students have
deleted the correct
records and that
everyone is caught up to
the same place in the
lesson.



ACTIVITY 1-3
Filtering Records

Before You Begin
My_Author_Data_03.xlsx is open.

Scenario
Now that you've fixed the data errors, you're ready to filter the data in preparation for creating some
reports.
You're looking for answers to the following questions:
• Who are the top 10 authors by income earned?
• Who are the top 5 authors by number of books sold?
• How many authors have been with F&A for 1 year or less?
• Which authors have been with F&A for less than 5 years and have sold more than 500,000

books?

1. In My_Author_Data_03.xlsx, filter the dataset to display only the top 10 income earners.
a) In cell G1, click the drop-down list arrow and select Number Filters→Top 10.
b) Select OK.

2. Filter the dataset to display only the top 5 authors by number of books sold.

a) Select DATA→Sort & Filter→Clear.
b) In cell E1, select the drop-down arrow and then select Number Filters→Top 10.
c) In the middle box, set the value to 5.

 

 
d) Select OK.

3. Enter a filter to determine how many authors have been with F&A for one year or less.
a) Clear the previous filter.
b) Select the entire table, and then drag it down three rows, effectively inserting three rows above the

header row.
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Ask students (either
onsite or remote),
Which author is the

highest earner?  Direct
answers to, AuthorID
2907 is the highest
earner with
$16,332,296.04 earned.
Remind students that
after they do the filter,
they can then sort the
Income Earned column
from largest to smallest.
Some students might go
straight to the Number of
Books Sold column and
sort for the top 5.
However, if they do this,
they won't get anything
returned because they
have not yet cleared the
previous top 10 income
earned filter. If students
find themselves in this
situation, direct them to
the DATA tab, Sort &
Filter group, and have
them select the Clear
button to clear the last
filter. Remind them that
if they want to run a new
filter, they should always
clear the previous filter
first.
Ask students, Which
author has the highest
number of books sold?
The answer is AuthorID
2723 with 699,988
books sold.



 
c) Copy the table's header row to row 1.

 

 
d) In cell C2, type <=1
e) Press Enter.
f) Select any cell within the dataset table.
g) Select DATA→Sort & Filter→Advanced.
h) In the Advanced Filter dialog box, verify that the correct range has been selected for the dataset

table ($A$4:$K$816).
i) In the Criteria range text box, type $A$1:$K$2
j) Select OK.
k) Select any cell within the dataset table.
l) If not selected, select the TABLE TOOLS DESIGN contextual tab, and then, in the Table Style

Options group, check the option Total Row.
 

 
m) From the drop-down list in cell C817, select Count.
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If necessary, let students
know that the screen
captures are showing
just the first few columns
of the worksheet. They
should be copying the
entire header row to row
1.

Ask students (either
onsite or remote), After
pasting the header row
into row 1, did any of
you notice that you also
copied the formatting?  If
anyone did, let them
know that's okay for this
exercise. A possible
reason for this is that
those who copied the
formatting selected the
range A4:K4 and pasted
that rather than selecting
the entire row.



 

 

4. How many authors have been with F&A for one year or less?
A: 48 authors have been with F&A for one year or less.

5. Clear all filters.

6. Save your work.
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TOPIC C
Use Summary and Database Functions to
Calculate Data
Raw data has value only when you begin to analyze it. As you continue developing your Excel skills,
you'll learn that combining various methods of data manipulation will enable you to view your data
in entirely new and, sometimes, unexpected ways.
Sorting and filtering data in tables provides new perspectives on your data. These new perspectives
enable you to make the types of business decision that can drive innovation, change, and growth.
However, by combining the data views, sorting and filtering, and Excel's powerful calculation
capabilities, you can create new, richer views of your data that can further enhance business
performance.
In this topic, you will use functions to calculate data.

Subtotals
Subtotals are functions that summarize values based on a specific range of data within a dataset. The
dataset must be a range and not a table. Subtotals can return various calculations such as the
AVERAGE or SUM of the subset of data.
Any cell that contains a SUBTOTAL function is not included in a grand total calculation.
In this example, the worksheet is sorted by Royalty Rate. The SUBTOTAL function returns the
average Income Earned for each royalty rate.

Figure 1-9: The SUBTOTAL function.
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The SUBTOTAL
Function
Be sure you display the
slide, and then ask
students (either onsite or
remote), What does the
1  in the function stand
for?  Direct students to
the Function Reference
in the Excel help system
to find the answer. The
answer is, 1 indicates
this subtotal function
calculates the average.
Then ask students, If
you wanted to change
the subtotal in the figure
so that it now calculates
the total income earned
for each royalty rate and
ignores any hidden
values, what would the
function in cell G10 look
like?  The answer is
SUBTOTAL(109,G5:G9

).  Be sure to reinforce
that the 109  in this
example and the 1  in
the figure tell Excel what
calculation to make and
whether or not the
calculation should
include hidden values.
Continue directing
students to the Function
Reference in the Help
system to find answers
to these types of
questions.



How to Summarize Range Data by Using Subtotals
This procedure will help you summarize range data by using subtotals.

Summarize Range Data with Subtotals
To summarize range data with subtotals:
1. Verify that the data you want to summarize is in a range and not in a table.
2. Select the range, including the header row, of the data you want to add subtotals to.
3. Select DATA→Outline→Subtotal.
4. In the Subtotal dialog box, from the At each change in drop-down list, select the field that will

indicate where each subtotal calculation should appear.
5. From the Use function drop-down list, select the type of calculation you would like to perform

for the subtotal.
6. In the Add subtotal section, select the field on which the subtotal will be calculated.
7. As necessary, check or uncheck the Replace current subtotals, Page break between groups,

and Summary below data check boxes.
8. Select OK.
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ACTIVITY 1-4
Using Subtotals with Range Data

Before You Begin
My_Author_Data_03.xlsx is open.

Scenario
You are on your way to a meeting. You need to report the total income earned for the entire group
of authors. However, your manager has also indicated she would like to know not only the total for
all of the authors but the subtotal for each group of authors when they are grouped by royalty rate.
Because you are in a hurry to get to the meeting, rather than take the time to develop and test
functions that can perform the calculations, you decide to quickly convert the table to a normal
range and then subtotal the range by income earned per royalty rate.

1. In My_Author_Data_03.xlsx, convert the Author_Data table to a normal range.
a) Select any cell in the table.
b) Select TABLE TOOLS DESIGN→Tools→Convert to Range.
c) In the Microsoft Excel dialog box, select Yes.

2. Add subtotals for the total income earned by authors when they are grouped by royalty rate.
a) Select any cell within the dataset range.
b) Select DATA→Sort & Filter→Sort.
c) In the Sort dialog box, under Column, select Royalty Rate.

 

 
d) Verify that Sort On is set to Values and Order is set to Smallest to Largest, and then select OK.
e) Select any cell within the dataset range.
f) Select DATA→Outline→Subtotal.
g) In the Subtotal dialog box, from the At each change in drop-down list, select Royalty Rate.
h) Verify that Use function is set to Sum.
i) In the Add subtotal to list, check IncomeEarned and then uncheck any other items that might be

selected. IncomeEarned should be the only option checked.
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Before continuing, verify
that all of the students
have selected Royalty
Rate from the At each
change in drop-down
list.



j) Verify that Replace current subtotals is checked, Page break between groups is unchecked, and
Summary below data is checked.
 

 
k) Select OK.

3. Save your work.

4. Format the range so that the bold items appear to the left of the subtotals.
a) Select cell K156 and drag it to cell F156.
b) By using the same technique, move the contents of cell K321 to cell F321 and the contents of range

K819:K820 to range F819:F820.
c) If necessary, adjust the width of column G to accommodate the values.

5. Collapse the dataset so it shows only the subtotals for each royalty rate and the Grand Total.
a) In the Outline pane, click the minus sign immediately to the left of row 156.

 

 
b) By using the same procedure, collapse the ranges for the 15% royalty rate and the 20% royalty rate.

 

 

6. Save your work.
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Before continuing, verify
that everyone has the
same selections in the
Subtotal dialog box.
Make sure only
IncomeEarned is
checked in the Add
subtotal to list.

Ask students (either
onsite or remote), Is
there a faster way to
collapse the dataset?
Direct answers to, Yes,
you can click the 2 in the
outline pane at the left.



Summary Functions in Tables
Subtotals work only with data that is in a range and not in a table. However, you can still subtotal
data in tables by using summary functions. Summary functions are subtotal functions that summarize
data in the totals row for a specified range within a table.
To leverage the power of summary functions in tables, it's generally a good idea to add a total row to
the table first, indicate what type of summary calculations you're looking for, and then sort and filter
your data.
In this example, the table has been filtered to display only the top five income earners in the dataset.
Then, the top five earners were sorted from highest earner to lowest. The total row uses three
summary functions that return relevant calculations for the filter: Years Under Contract is counted
and returns the total number of records returned; Number of Books Sold is totaled; and Income
Earned is averaged. So, this total row contains COUNT, SUM, and AVERAGE subtotals.

Note: To explore a way to streamline how you write functions associated with tables, you can
access the LearnTO Use Structured References to Calculate Data in an Excel Table
presentation from the LearnTO tile on the LogicalCHOICE Course screen.

Figure 1-10: A table's total row with summary functions.

In this example, the table has been filtered to display all of the authors with earnings between $1
million and $2 million. However, no changes were made to the total row. The only thing that
changed is the filter. The total row automatically adjusts its calculations based upon the filter criteria.

Figure 1-11: An updated total row.
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Summary Functions in
Table Total Row:
Example 1

You may want to show
LearnTO Use Structured
References to Calculate
Data in an Excel Table
from the LogicalCHOICE
Course screen or have
students navigate out to
the Course screen and
watch it themselves as a
supplement to your
instruction. If not, please
remind students to visit
the LearnTOs for this
course on their
LogicalCHOICE Course
screen after class for
supplemental
information and
additional resources.

Ask students, What do
you notice about the
SUBTOTAL function for
the Total row?  Direct
answers to In a table's
total row, summary
functions use the
category range enclosed
in brackets.  Point out
that in these examples,
the categories are
Income Earned and
Number of Books Sold,
respectively.
Summary Functions in
Table Total Row:
Example 2



How to Summarize Table Data by Using Summary Functions
This procedure will help you summarize table data by using summary functions.

Summarize Table Data with Summary Functions
To summarize table data with summary functions:
1. Verify that the data you want to summarize is in a table and not in a range.
2. Select any cell within the table.
3. On the TABLE TOOLS DESIGN tab, in the Table Style Options group, check Total Row.
4. Use the drop-down list options in the Total row to select the type of summary function you

would like to apply for each field that requires a calculation.
5. Sort and filter the table data as needed.
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ACTIVITY 1-5
Using Summary Functions in Tables

Before You Begin
My_Author_Data_03.xlsx is open.

Scenario
You've just returned from the meeting where you presented the subtotals for income earned when
the authors are grouped by royalty rate.
One of the action items you took away from the meeting is to make it easy for users of the Author
Data worksheet to quickly count how many authors fit a given criteria.
Specifically, you'd like to know how many authors signed their initial contract in the calendar year
2011.
You suspect this isn't the only question you'll have to ask of the data, so you decide to add a Total
row so that you can sort and filter the data as needed and have the Total row dynamically change its
output depending on what question needs to be answered.

1. In My_Author_Data_03.xlsx, remove the subtotals rows and then convert the Author_Data range into a
table that includes a Total row.
a) To expand the entire dataset, select 3 in the Outline pane.

 

 
b) Select rows 156, 321, 819, and 820.
c) Right-click any one of the selected rows, and then select Delete.
d) Select any cell in the dataset, and then select INSERT→Tables→Table.
e) In the Create Table dialog box, verify that the entire range =$A$4:$K$816 is selected, and then

select OK.
f) On the TABLE TOOLS DESIGN contextual tab, in the Table Style Options group, check Total Row.

2. Use the Total row and filtering to answer the question, How many authors signed their initial contract in
the calendar year 2011?
a) Select cell B817.
b) From the drop-down list, select Count.
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If necessary, remind
students that to select
multiple rows that are
not contiguous, they
should hold down the
Ctrl key and then select
the row header for each
row.



 
c) From the AutoFilter list for the Initial Contract Date, select Date Filters→Between.
d) Adjust the settings in the Custom AutoFilter dialog box so Initial Contract Date is after or equal to

1/1/2011 And is before or equal to 12/31/2011.
 

 
e) Select OK.

3. How many authors signed their initial contract in the calendar year 2011?
A: 64 authors signed their first contract in 2011.

4. Clear all filters.

5. Save your work.

Database Functions
Database functions are functions that return calculations for a range of data that meet specific criteria.
Mathematically, database functions perform the same way as standard functions. The SUM function
adds all the values in a range and the DSUM function (the database version of SUM) also adds all
the values in range. The key difference is that standard functions calculate data based on a range
while database functions calculate data that meet specific criteria within a range.
In this example, the SUM function on the left provides a total for the entire named range
Number_of_Books_Sold. The DSUM on the right identifies the range A4:K1077 as the database.
This DSUM wants to sum values in the Number of Books Sold field (E4). And, specifically, it only
wants the sum for all authors who have more than 23 books in print and have also sold more than
650,000 books. The total number of books sold for this subset of the data is 4,062,342.
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Verify that students are
using the AutoFilter list
in column B.

Compare SUM to DSUM
Ask students, What is
the syntax for database
functions?  Direct them
to the function reference
in the Excel help system
for the answer. Direct
answers to, All
database functions use
the same syntax:
DATABASE_FUNCTION
_NAME(database, field,
criteria).



Figure 1-12: Compare SUM to DSUM

How to Summarize Data by Using Database Functions
This procedure will help you summarize data by using database functions.

Summarize Data with Database Functions
To summarize table data with database functions:
1. Create the criteria range, inserting enough rows above the table or range so that:

• The criteria range contains a header row that matches the header row of the dataset.
• In addition to the criteria range header row, there are enough rows to accommodate the total

number of OR criteria you want to filter for. Database functions use criteria ranges in the
same way advanced filtering uses criteria ranges. Criteria on the same row use the AND
operator. Criteria on separate rows use the OR operator.

• There is one blank row between the new rows and the header row of the dataset.
2. Copy the header row of the dataset to the first row of the criteria range.
3. Enter filter criteria in the criteria cells.
4. Select the cell that will contain the database function.
5. In the Formula bar, type the database function using the entire dataset as the database

argument, the column label of the column you want to run the calculation on as the field
argument, and the criteria range as the criteria argument.

6. Press Enter.
7. Verify that the function works as planned.
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ACTIVITY 1-6
Using Database Functions

Before You Begin
My_Author_Data_03.xlsx is open.

Scenario
You're being asked more and more often for summary data based on various criteria. Although
sorting and filtering are very powerful, you feel it would be much faster to gather the needed data if
you could just type the required criteria into a criteria range and then have a function provide you
with the answer. After some research, you've concluded that you'll use database functions to answer
the following questions:
• How many authors signed their initial contract in April 2011?
• What is the average number of books sold for authors who signed their initial contract in the

fourth quarter of 2009 and who have earned more than $1 million?
You'll begin by moving the criteria range from the Author_Data worksheet to its own worksheet.
You'll then add the database functions to answer the questions.

1. In My_Author_Data_03.xlsx, move the criteria range from the Author_Totals worksheet to its own
worksheet named Criteria, and then rename the Author_Totals worksheet Data.
a) On the Author_Totals worksheet, select the range A1:K3.
b) Right-click and then select Cut.
c) Select the Sheet2 tab.
d) With cell A1 selected on Sheet2, press Ctrl+V.
e) Rename the Sheet2 worksheet Criteria.
f) Rename the Author_Totals worksheet Data.
g) On the Data worksheet, select rows 1, 2, and 3.
h) Right-click any of the selected rows and select Delete.
i) Arrange the worksheets so they are in the order Statistics, Criteria, and then Data.

2. On the Criteria worksheet, add a second column for Initial Contract Date.
a) On the Criteria worksheet, clear the contents of cell C2.
b) Select cell A10, type Answer, and then press Enter.
c) On the Statistics worksheet, select cell A8, and then select HOME→Clipboard→Format Painter.
d) On the Criteria worksheet, select cell A10.

Note: When you want an advanced filter or database function to use criteria
between a range of dates or numbers, add another column to the criteria
range and give the new column the same label as field you want to search
through.

e) Add a new column between the current columns B and C, and then copy the contents of cell B1 to
cell C1.
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Before continuing, verify
that all students have
made these adjustments
to their workbooks.



 

3. In preparation for counting the number of authors who signed their initial contract in April 2011, add a
DCOUNT function to the Criteria worksheet.
a) On the Criteria worksheet, select cell B10.
b) Select FORMULAS→Function Library→Insert Function.
c) In the Search for a function text field, type dcount and then select Go.
d) In the Select a function list, double-click DCOUNT.
e) In the Function Arguments dialog box, select the Collapse Dialog button for Database.
f) Select the Data worksheet, and then select the range A1:K813.
g) Press Enter.
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h) Select the Collapse Dialog button for Field.
i) Select the Data worksheet, select cell B1, and then press Enter.
j) Select the Collapse Dialog button for Criteria.
k) On the Criteria worksheet, select the range A1:L2 and then press Enter.
l) In the Function Arguments dialog box, select OK.
m) Save your work.

4. Using the criteria range, answer the following question: How many authors signed their initial contract
in April 2011?
a) On the Criteria worksheet, select cell B2, and then type >=4/1/2011 and press Enter.
b) Select cell C2, and then type <=4/30/2011 and press Enter.
c) If necessary, adjust the width of the columns so the text fits without overlapping other cells.
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Before continuing, check
in with students to
ensure their Function
Arguments dialog box
matches yours.
Before continuing, check
in with students to
ensure their Function
Arguments dialog box
matches yours.
Before continuing, check
in with students. At this
point, cell B10 on the
Criteria worksheet
should have the value
812. It's at 812 right now
because there are no
criteria set at this point.
The criteria will be set in
the next step.



 

5. Use the criteria range to answer the following question: What is the average number of books sold for
authors who signed their initial contract in the fourth quarter of 2009 and who have earned more than $1
million?
a) Change the contents of cell B2 to >=10/1/2009.
b) Change the contents of cell C2 to <=12/31/2009.
c) Type >1000000 in cell H2.
d) Select cell B10, and then, in the Formula bar, change DCOUNT to DAVERAGE.

 

 
e) Change Initial Contract Date to Number of Books Sold.

 

 

6. Save and close your work.
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Ask students (either
onsite or remote), How
many authors signed
their initial contract in
April of 2011?  The
answer is 2.

Ask students (either
onsite or remote), What
is the average number of
books sold for authors
who signed their initial
contract in the fourth
quarter of 2009 and who
have earned more than
$1 million?  The correct
answer is 410,583.
Before continuing, verify
that all students have
correctly applied the new
DAVERAGE function.



Summary
In this lesson, you created and modified tables, sorted and filtered the data in tables, and used
functions to calculate data.
By storing data in tables and leveraging Excel's powerful calculation, filtering, and sorting
functionality, you open the door to deep business intelligence and analysis. With your data
structured in tables, it's much easier to sort and filter the data to locate the information you need to
make sound business decisions.

Tables, subtotals, database functions, sorting, and filtering . . . these are all very powerful tools for
analyzing data. How might you leverage these tools either individually or in combination with each other to
mine the data in your company?

A: Answers will vary, but think about the data your company collects and how each of these types of
functionalities in Excel could provide insight into the business. For example, if you were to place
product sales data in a table, then filter the data to focus on a particular product, and then sort that
product's sales volume by geographical region, what might the sorting and filtering potentially reveal
about the product's sales?

Consider the types of data you work with in your company. What are some questions you might ask of the
data and how would you use database functions to help you find the answers to your questions?

A: Answers will vary, but remember that database functions enable you to locate data that meet specific
criteria. For example, if you work in an IT department, you could use the DAVERAGE function to
answer the question, What is the average amount of time per day sales representatives in North
America spend accessing the Sales Portal?

Note: Check your LogicalCHOICE Course screen for opportunities to interact with your
classmates, peers, and the larger LogicalCHOICE online community about the topics covered in
this course or other topics you are interested in. From the Course screen, you can also access
available resources for a more continuous learning experience.
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Encourage students to
use the social
networking tools
provided on the
LogicalCHOICE Home
screen to follow up with
their peers after the
course is completed for
further discussion and
resources to support
continued learning.





Visualizing Data with
Charts
Lesson Time: 1 hour

Lesson Objectives
In this lesson, you will:

• Create a chart.

• Modify and format charts.

• Create a trendline.

• Create advanced charts.

Lesson Introduction
You've built worksheets and workbooks that leverage the power of various formulas and
functions. These formulas and functions have enabled you to analyze your business data in
powerful ways. Up to this point, you've been working primarily with tabular data. You're
now ready to begin visualizing your data in new ways to help deepen your knowledge of
your business.
In this lesson, you will visualize data by using charts.

2



TOPIC A
Create Charts
Data visualization techniques begin with a fundamental understanding of how charts enable you to
view your data in ways that are at best challenging and at times virtually impossible when the data
appears strictly in a tabular format. Compare these two presentations of the same data. And when
you do, keep in mind this is a very simple, two-column, five-row dataset. Imagine a dataset 10, 20, or
30 columns wide by thousands or millions of rows deep.
Which version makes it easier to grasp the relative size of each market compared to the whole
quickly?

Figure 2-1: Data in a table.

Figure 2-2: Data in a chart.

When a gourmet chef prepares a meal, she works with a variety of individual ingredients. Often, the
chef will purchase these ingredients from a store or wholesale market that sells thousands of
different individual ingredients. In fact, hundreds of chefs might shop at the same market, but every
chef will select different ingredients for every meal because every diner has different expectations,
needs, and desires. Even chefs who select the exact same ingredients will often prepare completely
different meals.
You could think of the market where the chefs shop for ingredients as your tabular data. It's the
raw, individual pieces collected in one place.
But diners don't go to a gourmet restaurant to eat individual ingredients; they go to a gourmet
restaurant to eat beautifully prepared and presented meals.
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The activities in this
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When you create charts that present the data in new and valuable ways, you are like a chef who
selects the best individual ingredients in the right amounts and combines them in the best ways for
consumption by others.

Charts
Charts are non-tabular representations of tabular data. They enable users of data to see relationships,
patterns, and trends in the data that, if the data were to remain in a table, would be difficult or
impossible to see.

Note: To explore one way to incorporate an Excel chart in another application, you can access
the LearnTO Save an Excel Chart as a Picture presentation from the LearnTO tile on the
LogicalCHOICE Course screen.

Chart Types
Excel 2013 includes 11 chart types for presenting data. The types appear in the left pane of the
Insert Chart dialog box. Each chart type comes in a variety of sub-types. For example, there are 19
types of Column charts.

Figure 2-3: The Insert Chart dialog box.

This amounts to 73 chart types in Excel 2013, each of which can be individually customized and
combined with other chart types to handle nearly any conceivable data visualization need you may
have. Charts may also include animated graphs related to things like corporate sales, profits, and
customer satisfaction. When data is changed, the corresponding graph reflects the change.
Here's a brief explanation and example of each chart type.
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Chart
Type

Use To

Column Visualize the relationship of parts to each other. Example: You have production data
on today's output of ten crude oil wells and you want to quickly identify which well has
the highest production for the day.

Line Visualize data over time. Example: You are presenting the previous year's financial
stats at the annual shareholders meeting, and you want to illustrate for participants the
growth in the firm's return on capital employed over each of the previous four
quarters.

Pie Visualize the relationship of a part to a whole. Example: You have demographic data
on the languages spoken in Botswana and you want a visual representation of the
percentage each language represents of the whole.

Bar Visualize the relationship of parts to each other. The primary difference between bar
and column charts is that bar charts have a horizontal orientation compared to the
vertical orientation of column charts.

Area Visualize the change over time of multiple categories of data. Example: You want to
compare the change in consumption of a country's energy sources—nuclear, coal, oil,
gas, and renewables—over the last ten years.

XY
(Scatter)

Visualize the relationship between two variables. Example: You want to compare the
performance of two servers in a data center and you want to compare them based on
the number of requests they receive per second and their response time in seconds.

Stock Visualize the changes in stock prices over time. Example: You are analyzing your
company's stock performance over time and want to show the opening, high, low, and
close prices for a selected series of dates.

Surface Create a three dimensional representation of data. Usually, in a surface chart, you have
at least three variables you want to display. Example: You want to illustrate the
number of new retail outlets built per month over the last ten years.

Radar Visualize data for multiple variables by showing the relationship between each variable
based on a set of criteria. Example: You want to compare the average wind speed in
three regions over the last 12 months.

Combo Create a combination chart by selecting at least two series of data.

Chart Insertion Methods
There are two primary methods for inserting charts. You can:
• Select a chart by selecting Charts in the Quick Analysis dialog box.
• Select a chart from the Charts group on the INSERT tab. Use this method when you want to

select a specific chart type.
You can also press F11 to insert the default chart type. You can set any chart type to be the default
type. When you press F11, Excel automatically inserts that type of chart into your workbook. Using
the default chart type is beneficial when you know you will be entering many charts of the same
type.

How to Create Charts
Use these procedures to create charts.

Note: Access the Checklist tile in the LogicalCHOICE Course screen to view all How To
procedures for this lesson.
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Create a Chart by Selecting the Chart Type
To create a chart by selecting the chart type:
1. On a worksheet, select the data you want to include in the chart.
2. On the INSERT tab, in the Charts group, select the down-arrow of the chart type you would

like to insert, and then select the sub-type.

Create a Chart by Using the Quick Analysis button
To create a chart with the Quick Analysis button:
1. On a worksheet, select the data you want to include in the chart.
2. Move the mouse pointer over the right bottom corner of your selection to display the Quick

Analysis button.
3. Select the Quick Analysis button.
4. From the top of the menu, select Charts.
5. Select the chart of your choice.

Set the Default Chart Type
To set the default chart type:
1. To open the Insert Chart dialog box, press Alt+N+K. Note: Even if you are not inserting a

chart at the time, you must select a data range for the keyboard shortcut to open the Insert
Chart dialog box.

2. Select the All Charts tab.
3. In the left pane of the Insert Chart dialog box, select the type of chart you'd like to set as the

default type.
4. At the top of the right pane, right-click the desired chart subtype, and then select Set as Default

Chart.
5. Select OK.

Create a Chart by Using the Default Chart Type
To create a chart by using the default chart type:
1. Set the default chart type.
2. On a worksheet, select the data you want to include in the chart.
3. Press F11.

Create a Chart Template
To create a chart template:
1. Select the chart you want to save as a template
2. Right-click and select Save As Template.
3. In the Save Chart Template dialog box, type a filename and select Save.
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ACTIVITY 2-1
Creating Charts

Data Files
C:\091015Data\Visualizing Data with Charts\Author_Data_04.xlsx

Before You Begin
Excel 2013 is open.

Scenario
You are building out the Sales Dashboard worksheet and are now ready to add a chart to help
visualize the data in Total Sales by Fiscal Year table.

1. Open the file Author_Data_04.xlsx.

2. Beneath the bar chart, add a line chart that shows the units sold per fiscal year per media format.
a) On the Sales Dashboard spreadsheet, select the range AK2:AL15.
b) Select INSERT→Charts→Insert Line Chart, and then, in the 2-D Line section, select Line.

 

 
c) Drag the line chart so that it appears below the bar chart.
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3. Save your work as My_Author_Data_04.xlsx
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TOPIC B
Modify and Format Charts
Creating charts places the chart in your workbook. However, in the vast majority of cases, you will
need to modify some aspect of the default settings to meet your specific business needs.

The Difference Between Modifying and Formatting
Modifying and formatting charts go hand-in-hand. While these terms might be used synonymously,
generally speaking, modifying charts changes things such as the layout, position, and type of chart
(think “working with the chart's data”), whereas formatting charts changes things such as the color
of the data series, the size of the font, border of the chart shape, or the size of the chart (think
“working the look and feel of the chart”).

Chart Elements
Every chart has some number of chart elements. Chart elements include items such as chart titles,
data series, data labels, axes, data tables, and legends.
Every chart type has its own available elements. For example, although bar and column charts have
two axes, and surface charts have three axes, pie charts do not have any axes. Every chart type does
include at least one data series element.

Minimize Extraneous Chart Elements
When creating a chart, include only those elements that are 100% essential for conveying meaning.
As you develop your charting skills, you might be inclined to begin adding multiple chart elements
to ensure no meaning is lost for chart users. Indeed, it's not a bad idea to add many chart elements
when you first insert a chart. However, cluttered charts impede the transfer of knowledge, so, once
you've added all the chart elements you think your target audience is going to need, start stripping
them away until all that is left are only those elements that are 100% necessary.
Always keep your target audience in mind, and ask yourself questions such as:
• If I remove the gridlines, will the chart still convey meaning?
• Do I need a legend? Can I remove the legend and use data labels instead?
• For axes that include numerical values, what level of precision do I need? Must the axes include

one, two, three, or more decimal places, or, for the purposes of the chart, can I round the values
on the axes? Will “30” do in place of “30.1” or “30.125” or “30,125,978”?

• For axes that include text, can I abbreviate anything? Will “J” or “Jan” do in place of “January”?
• Do I really need axes titles?
• Do I really need that 3D effect?
• Does the data table actually aid understanding?
• Do I really need that many major and minor tick marks on each axis?
Before adding chart elements to a chart, considering the old adage “less is more.” If the chart
audience must have the element to get meaning from the chart, then use the element. Otherwise,
remove it.

CHART TOOLS Contextual Tabs
With a chart selected on a worksheet, Excel provides you with two CHART TOOLS contextual
tabs: DESIGN and FORMAT.
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Contextual Tab With a Chart Selected, Use This Group To (Group: Description)

 

 

Type: Change the chart's type or save the chart as a template.
Data: Switch the data position of the rows/columns or select
data.
Chart Layouts: Change the layout of the chart.
Chart Styles: Change the color style of the data series in the
chart.
Location: Move the chart from its current position to another
place in the workbook.

 

 

Current Selection: Select a specific chart element for formatting
and editing.
Insert Shapes: Add shapes to charts or worksheets that contain
charts.
Shape Styles: Apply a style to the shape of the chart.
WordArt Styles: Apply a style to the text in a chart.
Arrange: Position the chart relative to other items on the
worksheet.
Size: Specify the size of the chart.

How to Modify and Format Charts
Use these procedures to modify various components of a chart.

Change a Chart's Type
To change a chart's type:
1. Select the chart.
2. Select CHART TOOLS DESIGN→Type→Change Chart Type.
3. In the Change Chart Type dialog box, select the new type for the chart, and then select OK.
4. Edit the new version of the chart as necessary.

Change the Data Associated with a Chart
To change the data associated with a chart:
1. Select the chart.
2. Select CHART TOOLS DESIGN→Data→Select Data.
3. In the Select Data Source dialog box, set the chart's data range, and then select OK.

Change the Layout or Style of a Chart
To change the layout or style of a chart:
1. Select the chart.
2. If desired, change the chart layout.

• Select CHART TOOLS DESIGN→Chart Layouts→Quick Layout.
• Select the desired layout.

3. If desired, change the chart style.
• Select CHART TOOLS DESIGN→Chart Styles→More button
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.

• From the Chart Styles gallery, select the desired style.
4. Edit the chart elements as necessary.

Change the Location of a Chart
To change the location of a chart:
1. Select the chart.
2. Select CHART TOOLS DESIGN→Location→Move Chart.
3. In the Move Chart dialog box, select where you would like the chart to move to, and then select

OK.

Reposition Labels on a Chart
To reposition labels on a chart:
1. Select the chart.
2. Select CHART TOOLS DESIGN→Chart layouts→Add Chart Element, and then select

Data Labels.
3. Select one of the options on the menu.

Modify the Axes of a Chart
To modify the axes of a chart:
1. Select the chart.
2. Modify the axes.

• Select CHART TOOLS DESIGN→Chart Layouts→Add Chart Element→Axes, and
then select the desired option.

• Select CHART TOOLS DESIGN→Chart Layouts→Add Chart
Element→Axes→More Axis Options, and then, in the Format Axis panel, configure the
axes.

3. Close the Format Axis panel.
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ACTIVITY 2-2
Modifying Charts

Before You Begin
My_Author_Data_04.xlsx is open.

Scenario
You're still working on your sales dashboard. With the line chart in position, you're now ready to
modify it to better fit your needs.
Specifically, you are going to:
• Add a title to the chart to align with the look of the other charts.
• Give the chart a useful name.
• Edit the legend of the chart.
• Remove the gridlines.
• Add data labels.
• Assess the axes and their labels and edit them as needed.
You'll begin by changing the title of the line chart.

1. In My_Author_Data_04.xlsx, add a title to the line chart to align with the look of the other charts.
a) Select the line chart.
b) Select CHART TOOLS DESIGN→Chart Layouts→Add Chart Element→Chart Title→Centered

Overlay.
c) In the Formula bar, type Unit Sales by FY (in millions) and then press Enter.
d) On the chart, select the title text, and then, on the mini-toolbar, select the Font Size down-arrow.

 

 
e) Change the font size to 12.
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f) Save your work.

2. Give the line chart a useful name.
a) Select the line chart.
b) In the Name box, type Unit Sales by FY and then press Enter.

 

 

3. Edit the legend of the line chart for readability.
a) With the Unit Sales by FY chart selected, select CHART TOOLS DESIGN→Data→Select Data.

 

 
b) In the Select Data Source dialog box, in the Legend Entries(Series) list, verify that Units(Print) and

Units(Electronic) are selected.
c) Highlight Units (Print).
d) Select Edit.
e) In the Edit Series dialog box, verify that the contents of the Series name field is selected, and then

type Print
f) Select OK.

Note: When you change the legend text in this way, you remove the link
between the item in the legend and the data source cell—in this case, cell
AK2.

g) Using the same method, change the name of the Units(Electronic) legend entry to Electronic.
h) In the Select Data Source dialog box, select OK.
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4. Remove the gridlines.
a) On the Unit Sales by FY chart, to select all of the vertical axis gridlines at once, select the gridline for

50000000.
 

 
b) Press Delete.
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5. Add data labels.
a) On the Unit Sales by FY chart, right-click the Electronic line, and then select Add Data Labels.
b) Right-click the 55724773 data label, and then select Format Data Labels.
c) In the Format Data Labels panel, expand the Number menu.

 

 
d) In the Category drop-down list, select Custom.
e) In the Type drop-down list, select $#,##0.0,,
f) In the Format Code field, delete the dollar sign ($).
g) Select Add.
h) On the chart, delete all of the data labels except 55.7.
i) On the chart, select the Print line, add data labels in the same format, deleting all but the 23.3 label.
j) Drag the 23.3 label so that it appears just below the Print line.
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Delete.



 
k) Save your work.

6. Edit the axes and their labels as needed.

a) On the Unit Sales by FY chart, right-click the X axis labels and then select Select Data.
b) In the Select Data Source dialog box, under Horizontal (Category) Axis Labels, select Edit.
c) In the Axis Labels dialog box, select the Collapse Dialog button, and then, on the Sales Dashboard

worksheet, select the range AJ3:AJ15 and press Enter.
 

 
d) Select OK twice, and then scroll back to the chart section of the worksheet.
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e) Right-click the Y axis and select Format Axis.
f) In the Format Axis panel, expand the NUMBER menu.
g) In the Category drop-down list, select Custom, and then, in the Format Code text field, type ##0,,
h) Select Add.

 

 

7. Resize the line chart.
a) Select the line chart.
b) On the Format Chart Area panel, if necessary, select the Size & Properties tab

 

 
.

c) Expand the Size section, and then select the Height down-arrow until the height equals 2.5 .
d) Set the width of the chart to 4.8 .
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e) Save your work.

8. Edit the Unit Sales by FY chart for readability.
a) On the Unit Sales by FY chart, right-click the Legend and select Format Legend.
b) In the Format Legend panel, verify that the Legend Options tab is selected, and then, under Legend

Position, select Top.
 

 
.

c) On the chart, drag the legend so it is centered below the chart title.
 

 
d) Right-click the X axis and select Format Axis.
e) In the Format Axis panel, verify that the Axis Options tab is selected, and then, under Axis Position,

select On Tick Marks.
f) Drag the 55.7 and 23.3 data labels so they are above and below their data lines, respectively.
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9. Right-click the Electronic data line and select Format Data Series. Then, on the Fill & Line tab in the
Format Data Series panel, set the width of the line to 1.25 pt.

10. Close the Format Data Series panel.

11. Save your work.
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ACTIVITY 2-3
Formatting Charts

Before You Begin
My_Author_Data_04.xlsx is open.

Scenario
You are continuing work on your sales dashboard. You are now ready to format the charts.
Specifically, you are going to:
• Update the border color and thickness around the line chart.
• Decrease the gap width between the data points in the bar and column charts.
You'll begin by adding a border to the line chart.

1. In My_Author_Data_04.xlsx, update the border color and thickness of the line chart.
a) On the Sales Dashboard worksheet, select the line chart.
b) Select CHART TOOLS FORMAT→Shape Styles→More button→Colored Outline - Olive Green,

Accent 3.
 

 

2. What happened when you applied the green outline?
A: The outline was applied but the chart title's font size also increased. When you apply a built-in

style, everything in the selection will acquire the new style's attributes.

3. Return the line chart title to 12 pt size.
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4. Edit the bar and column charts so they have a smaller gap width between the data points.
a) On the bar chart, right-click the data series, and then select Format Data Series.

Note: In charts, the bars, columns, lines, pie pieces, etc. represent the data
series. You can right-click either bar to perform this procedure.

b) In the Format Data Series panel, set the Gap Width to 40%.
 

 
c) Set the gap width for the column chart data series to 40%.

5. Save your work.
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TOPIC C
Create a Trendline
A common business task is to project what the business will be doing in the near-, mid-, and long-
term. These projections could be anything from the number of units sold of a particular product to
the projected income of a proposed project.
The data you have is the data that will help you make these types of projections, and trendlines are
the Excel tool that will help you visualize those projections.

Trendlines
A trendline is a chart data series that makes predictions about the future state of the data based on
current trends in the data.
You can use trendlines to make predictions about virtually any type of data.
In this example, two trendlines predict the future trends for unit sales of books in an electronic
format (the steep, green dashed line), and unit sales of books in a print format (the gently sloping,
red dashed line).

Figure 2-4: Trendlines forecasting out two years.

Types of Trendlines
There are six types of trendlines available in Excel: Exponential, Linear, Logarithmic, Polynomial,
Power, and Moving Average. Each type of trendline has its own unique application.
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Trendline Type Description

 

 

A curved trendline for use with data that increases or decreases in value at ever
greater frequencies.

 

 

A straight trendline for use with data that essentially clusters in a straight line
pattern trend if the data is displayed as dots.

 

 

A curved trendline for use with data that either increases or decreases in value
rather quickly but then at some point begins to even out over time.

 

 

A curved trendline for use with data that either increases or decreases in value
but does not necessarily even out over time.

 

 

A curved trendline for use with data that increases or decreases at a
predetermined and steady rate.

 

 

A curved and/or straight trendline that follows the fluctuation in the average
values of data over a period of time.

The Format Trendline Panel
Use the Format Trendline panel to either add a new trendline or adjust and existing trendline. One
way to open the Format Trendline panel is to right-click the data series you want to add the
trendline to, and then select Add Trendline.
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Figure 2-5: The Format Trendline panel.

How to Create a Trendline
Use this procedure to create a trendline.

Create a Trendline
To create a trendline:
1. On the chart that will contain the trendline, right-click the data series to which you would like to

add the trendline, and then select Add Trendline.
2. In the Format Trendline panel, from the Trendline Options tab, select the type of trendline

you'd like to add.
3. In the Forecast section, enter the number of periods for which you would like the trend line to

forecast forward or backward.
4. Configure the other desired options.
5. Close the Format Trendline panel.
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ACTIVITY 2-4
Creating a Trendline

Before You Begin
My_Author_Data_04.xlsx is open.

Scenario
You want to project unit sales growth for both print and electronic books for the next two years.
Because you do not want to change the current version of the Unit Sales by FY chart, you've
decided to copy the chart, add trendlines to the copy, and then edit the new chart for readability.
You plan to add the new chart below the four charts currently on the sales dashboard.

1. In My_Author_Data_04.xlsx, create a copy of the Unit Sales by FY chart and then place the new version
under the existing charts on the Sales Dashboard.
a) On the Sales Dashboard worksheet, select the line chart.
b) Press Ctrl+C.
c) Select cell A24.
d) Press Ctrl+V.
e) Use the drag handles on the selected chart's border to increase the width of the new chart so that it

matches the combined width of the two charts above it.
 

 
f) In the Format Chart Area panel, select the Size & Properties tab.
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g) Set the new chart's height to 5.25 inches.
h) Change the title of the new chart to FORECAST: Unit Sales by FY (in millions).

 

 

2. Save your work.

3. Add a trendline that extends out two years for Print units.
a) With the FORECAST chart selected, select CHART TOOLS DESIGN→Chart Layouts→Add Chart

Element→Trendline→More Trendline Options.
b) In the Add Trendline dialog box, verify that Print is selected, and then select OK.
c) In the Format Trendline panel, on the Trendline Options tab, select the Power radio button.
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d) In the Trendline Name section, select the Custom radio button, and then, in the text box, type

Forecast and press Tab.
e) In the Forecast section, in the Forward text box, type 2
f) Check the Display R-squared value on chart check box.
g) Select the Fill & Line tab, and then, in the Dash type drop-down menu, select Dash.
h) Close the Format Trendline panel.

4. Create a similarly styled Exponential trendline that extends out two years for Electronic units. Be sure to
match the color of the Electronic trendline to the Electronic data series.
 

 

5. Save your work.

6. Position the R2=0.9751 trendline label under Print and Forecast in the legend, and position the
R2=0.9857 trendline label under Electronic and Forecast.

7. Increase the thickness of the Print and Electronic data series to 2.25 pt.

8. If necessary, position the 55.7 and 23.3 data labels so they are vertically aligned above 2012.
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9. Based on these trendlines, what does the data suggest?
A: The data suggests that in the next two years, F&A Publishing could see electronic book sales

increase dramatically while print book sales grow slowly.

10. Save your work.
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TOPIC D
Create Advanced Charts
Sometimes you need to visualize data based on two X and/or two Y axes. The additional axes help
chart users better grasp what the data is trying to tell them.

Dual Axes Charts
A dual axes chart is a chart that uses primary and secondary X and/or Y axes to convey meaning
about more than one measurement on a single chart.
In this example, the primary Y axis on the left ranges from $0 to $600 million. It represents the total
sales, in dollars, of all books sold in both print and electronic formats. This data is represented by
the columnar data series. The secondary Y axis on the right ranges from 0 to 140 million units (not
dollars). This represents the total number of units sold for the print format (the lowest solid line
data series ending at 2012), the electronic format (the solid line series ending about halfway up the
2012 column), and their combined total (the tallest solid line ending near the top of the 2012
column).
The advantage of a dual axes chart is that it consolidates the data into a single view—instead of
using more than one chart.

Figure 2-6: A dual-axes chart.

How to Create a Dual Axes Chart
Use this procedure to create a dual axes chart.

Create a Dual Axes Chart
To create a dual axes chart:
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A Dual-Axes Chart



1. Select the chart.
2. On the CHART TOOLS FORMATcontextual tab, in the Current Selection group, select the

data series for which you would like to add the secondary axis, and then select Format
Selection.

3. In the Format Data Series panel, on the Series Options tab, select the Secondary Axis radio
button.

4. Format the secondary axis as necessary.

Excel 2013: Data Tables and Charts  |  67

Towson University Lesson 2: Visualizing Data with Charts



ACTIVITY 2-5
Creating a Dual Axis Chart

Before You Begin
My_Author_Data_04.xlsx is open.

Scenario
The Forecast chart is coming along nicely. You've decided this chart could add even more value if it
also included the combined unit sales and monetary sales for each fiscal year.
To add these additional levels of data visualization to the existing Forecast chart, you will:
• Include the Units Combined and Sales (in millions) columns from the table in the data range for

the chart.
• Make the Sales (in millions) data the primary axis.
• Show the monetary sales as a column data series behind the unit sales line data series.
• Switch all three of the unit sales to the secondary axis.
You start by including the entire table in the data range.

1. In My_Author_Data_04.xlsx, delete the trendlines. You'll add them back in after you've added the
second axis.

2. Add the Units Combined and Sales (in millions) columns to the data range in the Forecast chart.
a) On the Sales Dashboard worksheet, right-click the FORECAST chart and select Select Data.
b) In the Select Data Source dialog box, select the Collapse Dialog button to the right of the Chart data

range field.
c) On the Sales Dashboard worksheet, scroll to and select the range AJ2:AN15, and then press Enter.

 

 
d) What do you notice about the range?
A: Once you've selected the entire range, the range reverts to the table's name—

tblTotalSalesByFiscalYear. In other words, if you know you'll use a specific table as your data
range, you can type an equal sign and the table's name without having to select the range itself.

e) In the Select Data Source dialog box, select OK and then scroll back to view the FORECAST chart.

3. Switch the three unit sales lines to a secondary axis.
a) On the CHART TOOLS FORMAT contextual tab, in the Current Selection group, from the drop-

down list, select Series Units(Print)  and then, in the same group on the ribbon, select Format
Selection.

b) In the Format Data Series panel, from the Series Options tab, select Secondary Axis.
c) With the Format Data Series panel still open, on the CHART TOOLS FORMAT tab, in the Current

Selection group, from the drop-down list, select Series Units( Electronic)  and, in the Format Data
Series panel, select Secondary Axis.
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d) On the CHART TOOLS FORMAT tab, in the Current Selection group, from the drop-down list, select
Series Units(Combined)  and, in the Format Data Series panel, select Secondary Axis.
 

 
e) Save your work.

4. Format the numbers in the primary and secondary axes.
a) On the chart, select the primary Y axis. The task pane automatically changes to the Format Axis

panel.
b) In the Format Axis panel, from the Axis Options tab, expand the Number menu.

 

 
.

c) Under Category, select Custom.
d) In the Format Code field, type $#,##0,,
e) Select Add.
f) On the chart, select the secondary Y axis.
g) In the Format Axis panel, from the Axis Options tab, expand the Number menu.
h) Under Category, select Custom.
i) From the Type drop-down menu, select ##0,,
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state.



 
j) Save your work.

5. Change the chart type for the Sales (in millions) data series to Column.
a) On the chart, right-click the Sales (in millions) data series, and then select Change Series Chart

Type.
b) In the Change Chart Type dialog box, from the All Charts tab, in the right pane, from the Choose the

chart type and axis for your data series section, scroll down to the Sales (in millions) drop-down list,
select the down-arrow, and then, in the Column section, select Clustered Column.

c) Select OK.
d) Right-click any of the columns in the Sales (in millions) data series, and then select Format Data

Series.
e) In the Format Data Series panel, from the Fill & Line tab, expand the Fill section, and then select

Solid fill.
f) Set the Transparency to 70%.
g) If necessary, expand the Border section, and then select the No line radio button.
h) Close the Format Data Series panel.

 

70  |  Excel 2013: Data Tables and Charts

Lesson 2: Visualizing Data with Charts OTS Training

Check in with students.
Before proceeding,
verify that everyone's
charts are in the same
state.



 
i) Save your work.

6. Edit the X axis so that it displays years.
a) Right-click the X axis and select Select Data.
b) In the Select Data Source dialog box, under Horizontal (Category) Axis Labels select Edit.
c) In the Axis Labels dialog box, select the Collapse Dialog button, and then, on the Sales Dashboard

worksheet, select the range AJ3:AJ15.
d) Press Enter and then select OK.
e) In the Select Data Source dialog box, select OK.
f) If necessary, scroll to view the FORECAST chart.

7. Add trendlines that forecast out two years for Sales (in millions), Print Units and Electronic Units.
a) Right-click any of the columns in the Sales (in millions) data series and select Add Trendline.
b) Add a Power trendline named Forecast that looks forward 2 periods, displays its R-squared value,

and has a 2 pt dark blue solid line style.
c) Right-click the Units (Electronic) data series, select Add Trendline, and then add an Exponential

trendline named Forecast that looks forward 2 periods, displays its R-squared value, and has a 0.75
pt dark green dashed line style.

d) Right-click the Units (Print) series, select Add Trendline, and then add a Power trendline named
Forecast that looks forward 2 periods, displays its R-squared value, and has a 0.75 pt dark red
dashed line style.
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e) Save your work.

8. Edit the chart for readability.
a) With the FORECAST chart selected, select CHART TOOLS DESIGN→Data→Select Data.
b) Under Legend Entries (Series), select Units( Print) and then select Edit.
c) Clear the contents of the Series Name field and, in that field, type Print and select OK.
d) Change the name of Units(Electronic) to Electronic, the name of Units(Combined) to Combined, and

the name of Sales (in millions) to Sales.
e) In the Select Data Source dialog box, select OK, and scroll back to the chart.
f) On the chart, delete each of the Forecast legend entries, the Fiscal Year legend entry, the R2

values, and the 23.3 and 0.0 data labels.

9. Save and close your work.
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Summary
In this lesson, you created and modified charts.
Excel 2013 provides an enormous array of charts, from bar and column charts to pie and doughnut
charts to line, area, and scatter charts.
No matter which type of chart you need, always keep the chart user in mind. Ask yourself, which
chart type will work best to transfer knowledge as quickly and efficiently as possible? Once you've
identified which chart type you will use, focus on limiting the chart to displaying only those
components it will need to transfer the knowledge. Do you really need a legend and gridlines? Do
you need tick markets for every tenth of the Y axis measurement?

Consider the charts you've encountered at work. Perhaps you've presented some charts or have been in
meetings where charts have been presented. What did you learn from these charts?

A: Answers will vary, but you should think about the common types of charts you encounter in meetings
or documentation. For example, consider the bar, pie, or line charts you've seen in company
presentations. What about the charts made them easy or difficult to understand?

What would you add to or remove from the charts to enable them to better convey meaning?

A: Answers will vary, but consider removing anything from a chart that gets in the way of conveying
meaning. For example, if a column chart contains horizontal lines in the background, is any meaning
lost if those lines are removed?

Note: Check your LogicalCHOICE Course screen for opportunities to interact with your
classmates, peers, and the larger LogicalCHOICE online community about the topics covered in
this course or other topics you are interested in. From the Course screen, you can also access
available resources for a more continuous learning experience.
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their peers after the
course is completed for
further discussion and
resources to support
continued learning.


	Organizing Worksheet Data with Tables
	Create and Modify Tables
	

	Sort and Filter Data
	
	

	Use Summary and Database Functions to Calculate Data
	
	
	


	Visualizing Data with Charts
	Create Charts
	

	Modify and Format Charts
	
	

	Create a Trendline
	

	Create Advanced Charts
	


	Lesson Labs
	Solutions
	Index
	Blank Page

